Звуки в 1С

Версия для печатиPDF-версия

Платформа:

Сегодня меня заинтересовала новая тема - попытка заставить 1С-ку "говорить".

Пошерстив интернет я нашел один способ.

&НаКлиенте
Процедура Звук2(Команда)
   

oVoice = Новый COMObject("SAPI.SpVoice");    
            
    Если РежимВоспроизведения = "Из файла" Тогда
        
        Если ЗначениеЗаполнено(АдресЗвука) Тогда
            Текст = Новый ТекстовыйДокумент;
            Текст.Прочитать(АдресЗвука,КодировкаТекста.ANSI , Символы.ПС);
            Голос = "";
            Для Номер = 0 По Текст.КоличествоСтрок() Цикл
                Голос = Голос + Текст.ПолучитьСтроку(Номер);
            КонецЦикла;
        Иначе
            Голос = "Файл не найден";
        КонецЕсли;
        
        oVoice.Speak(Голос);
        
    Иначе
        Если Звук = "" Тогда
            Голос = "Пустая строка";
        Иначе    
            Голос = """" + Звук + """";
        КонецЕсли;
        oVoice.Speak(Голос);
    КонецЕсли;
        
КонецПроцедуры

&НаКлиенте
Процедура АдресЗвукаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка) Экспорт
    // Вставить содержимое обработчика.
    Режим = РежимДиалогаВыбораФайла.Открытие;
    
    ДиалогОткрытия = Новый ДиалогВыбораФайла(Режим);
    ДиалогОткрытия.ПолноеИмяФайла = "";
    Фильтр = "Текст, *.txt|*.txt";
    ДиалогОткрытия.Фильтр = Фильтр;
    ДиалогОткрытия.Заголовок = "Выберите текстовый файл для прочтения";
    Если ДиалогОткрытия.Выбрать() Тогда
        МассивВыбранныхФайлов = ДиалогОткрытия.ВыбранныеФайлы;
        Для Каждого ИмяВыбранногоФайла Из МассивВыбранныхФайлов Цикл
            ВыбранныйФайл = Новый Файл(ИмяВыбранногоФайла);
        КонецЦикла;
    Иначе
        Предупреждение("Нет выбранных файлов!");
    КонецЕсли;
    АдресЗвука = ИмяВыбранногоФайла;
        
КонецПроцедуры

С помощью данных процедур я могу заставить 1С проговорить текст из поля ввода или же из текстового файла. Но хотелось бы узнать другие варианты. Или как можно заставить 1С говорить другим голосом (наверняка же есть несколько вариантов)

Ну или совсем другие способы заставить говорить

И конечно же попробовать воспроизвести звуковой файл - тоже интересно.

Всё это я непременно сам буду искать, и если найду хороший вариант - приведу сюда, но вдруг кто-то уже нашел и может показать.