Здравствуйте, коллеги!

Версия для печатиPDF-версия

Платформа:

Это на ВнешнейОбработке, на форме.

&НаКлиенте
Процедура ПутьКФайлуНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;

ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);

ДиалогОткрытияФайла.Показать(Новый ОписаниеОповещения("ОбработкаВыбораФайла". ЭтаФорма));

//Если ДиалогОткрытияФайла.Выбрать() Тогда
//
// ПутьКФайлу = ДиалогОткрытияФайла.ПолноеИмяФайла;
//
//КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ОбработкаВыбораФайла(ВыбранныеФайлы.ДопПараметры) Экспорт

ПутьКФайлу = ВыбранныеФайлы[0];

КонецПроцедуры // ()

Выдает ошибку:

{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(9,78)}: Ожидается символ ')'
ДиалогОткрытияФайла.Показать(Новый ОписаниеОповещения("ОбработкаВыбораФайла"<<?>>. ЭтаФорма)); (Проверка: Сервер)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(9,89)}: Неопознанный оператор
ДиалогОткрытияФайла.Показать(Новый ОписаниеОповещения("ОбработкаВыбораФайла". ЭтаФорма)<<?>>); (Проверка: Сервер)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(20,46)}: Ожидается символ ')'
Процедура ОбработкаВыбораФайла(ВыбранныеФайлы<<?>>.ДопПараметры) Экспорт (Проверка: Сервер)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(9,78)}: Ожидается символ ')'
ДиалогОткрытияФайла.Показать(Новый ОписаниеОповещения("ОбработкаВыбораФайла"<<?>>. ЭтаФорма)); (Проверка: Тонкий клиент)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(9,89)}: Неопознанный оператор
ДиалогОткрытияФайла.Показать(Новый ОписаниеОповещения("ОбработкаВыбораФайла". ЭтаФорма)<<?>>); (Проверка: Тонкий клиент)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(20,46)}: Ожидается символ ')'
Процедура ОбработкаВыбораФайла(ВыбранныеФайлы<<?>>.ДопПараметры) Экспорт (Проверка: Тонкий клиент)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(9,78)}: Ожидается символ ')'
ДиалогОткрытияФайла.Показать(Новый ОписаниеОповещения("ОбработкаВыбораФайла"<<?>>. ЭтаФорма)); (Проверка: Веб-клиент)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(9,89)}: Неопознанный оператор
ДиалогОткрытияФайла.Показать(Новый ОписаниеОповещения("ОбработкаВыбораФайла". ЭтаФорма)<<?>>); (Проверка: Веб-клиент)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(20,46)}: Ожидается символ ')'
Процедура ОбработкаВыбораФайла(ВыбранныеФайлы<<?>>.ДопПараметры) Экспорт (Проверка: Веб-клиент)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(9,78)}: Ожидается символ ')'
ДиалогОткрытияФайла.Показать(Новый ОписаниеОповещения("ОбработкаВыбораФайла"<<?>>. ЭтаФорма)); (Проверка: Мобильный клиент)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(9,89)}: Неопознанный оператор
ДиалогОткрытияФайла.Показать(Новый ОписаниеОповещения("ОбработкаВыбораФайла". ЭтаФорма)<<?>>); (Проверка: Мобильный клиент)
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(20,46)}: Ожидается символ ')'
Процедура ОбработкаВыбораФайла(ВыбранныеФайлы<<?>>.ДопПараметры) Экспорт (Проверка: Мобильный клиент)

Что я делаю не так?

Для начала надо вместо точек запятые поставить.

Поставил уже. Но ситуацию это не меняет.

Какие теперь ошибки?