Запись значения в поле формы

Версия для печатиPDF-версия
Если Спр.НайтиПоНаименованию(СокрЛП(Эксель.Cells(Сч, 2).Value))<>Спр.ПустаяСсылка() Тогда
Фл=Справочники.СотрудникиОрганизаций;
Если Фл.НайтиПоНаименованию(Эксель.Cells(Сч, 2).Value)<>Фл.ПустаяСсылка() Тогда
сообщить(Фл.НайтиПоНаименованию(Эксель.Cells(Сч, 2).Value));
 
//загрузка инн, страхового и паспорта
ФЛП=Спр.НайтиПоНаименованию(СокрЛП(Эксель.Cells(Сч, 2).Value)).ПолучитьОбъект();
ФЛП.ИНН=Эксель.Cells(Сч, 5).Value;
Стр=СтрЗаменить(Эксель.Cells(Сч, 4).Value,"-","");
Стр=СтрЗаменить(Стр,"-","");
ФЛП.СтраховойНомерПФР=Стр;
// ФЛП.ПолеВводаПрочаяКИ=Эксель.Cells(Сч, 3).Value;
ФЛД=ФЛП.ЭтотОбъект;
ФЛД.ПолучитьФорму("ФормаЭлемента").ЭлементыФормы.Удостоверение=(Эксель.Cells(Сч, 3).Value);
ФЛД.Записать();
ФЛП.Записать();
 
Иначе
КонецЕсли;
Иначе
КонецЕсли;
КонецЦикла;
Выдает ошибку поле объекта недоступно для записи!

Какой-то хитрый алгоритм. Вообще-то, нужно значение реквизита менять непосредственно у соответствующего объекта, а не у реквизитов формы.

А ошибка скорее всего из-за того, что пытаетесь элементу формы присвоить строковое значение. Можно попробовать сделать так:

ФЛД.ПолучитьФорму("ФормаЭлемента").ЭлементыФормы.Удостоверение.Значение=(Эксель.Cells(Сч, 3).Value);

Но не знаю, поможет ли это решить задачу.

У него тип строка. Так тоже пробовала пропускает но все равно ругаеться на запись. Суть в том что его в реквизитах нет, есть только на форме поле. Как его записать?

Это скорее всего хранится в регистре сведений. Посмотрите, откуда там данные подставляются.

У меня сейчас под рукой такой конфигурации нет.

Речь точно о конфигурации Бухгалтерия государственного учреждения 2.0? Что-то не могу там найти справочник СотрудникиОрганизаций.

бУХГАЛТЕРИЯ АВТОНОМНОГО УЧРЕЖДЕНИЯ просто не было такой для выбора. Спасибо.

Не могу найти поля Удостоверение на форме Сотрудника организации. Какой релиз конфигурации?

Бухгалтерия автономного учреждения, редакция 2.0 (2.0.65.21) . Там закладку надо перелистнуть. Кажись там в физлицах спр.

А скриншот можете выложить?

Чуть попозже. Я сейчас переключилась на перенос для Зарплата образовательных учреждений. Вот там точно регистр. За два дня надо их перелопатить с начислениями удржаниями. А потом Бухой уже займусь. Если разберусь то решение скину, нет скрины да обработку дам посмотрим.

Вот на форме где сидит

Уже нашёл это Удостоверение. Во-первых, оно находится на форме физ.лица. А во-вторых, его значение формируется по данным регистра сведений ПаспортныеДанныеФизЛиц. Смотрите структуру регистра и добавляйте запись в регистр при загрузке данных.

Спасибо)))!!!!

С паспортом все получилось. А вот смотрите в Зарплате образовательного учреждения контактная информация, она заполняеться не в регистре а в модулях через формы, есть какой то способ ее заполнить, тип то впринципе строковый?

А где хранится контактная информация? В табличной части справочника?

Там табличка на форме а в табличных частях ее нету(. Тоже в ФизЛицах. Заполняеться через общие модули как то хитро.