Внешняя обработка

Версия для печатиPDF-версия
Не видит печатную форму. Функция СведенияОПечтнойФорме не найдена.
 
Процедура КнопкаВыполнитьНажатие(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "ПечатнаяФормаДляУПД");
        
    Если ПечатнаяФорма <> Неопределено Тогда
        
        ПечатнаяФорма.ТабличныйДокумент = СформироватьТабличныйДокумент(МассивОбъектов, ОбъектыПечати);
        ПечатнаяФорма.СинонимМакета = "Печатная форма для УПД";
        
    КонецЕсли;
        
КонецПроцедуры
Функция СформироватьТабличныйДокумент(МассивОбъектов, ОбъектыПечати)
    
    ТабДок = Новый ТабличныйДокумент;
    
Макет = ЭтотОбъект.ПолучитьМакет("Макет");
ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
    
    ПервыйДокумент = Истина;
    
    Для Каждого ОбъектСсылка Из МассивОбъектов Цикл
        
        Если Не ПервыйДокумент Тогда
            
            //выводим документы на разных страницах
            ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
            
        КонецЕсли;
        
        ПервыйДокумент = Ложь;
        
        НомерСтрокиНачало = ТабДок.ВысотаТаблицы + 1;
        
        ОбластьСтрока.Параметры.Документ = ОбъектСсылка;
        ТабДок.Вывести(ОбластьСтрока);
        
        //зададим область печати объекта в табличном документе
        УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабДок, 
            НомерСтрокиНачало, ОбъектыПечати, ОбъектСсылка);
            
    КонецЦикла;
        
    Возврат ТабДок;
    
КонецФункции 
 

Какая конфигурация?

Посмотрите в общем модуле УправлениеПечатью присутствует ли функция СведенияОПечатнойФорме? И вообще, есть ли этот модуль УправлениеПечатью?