В Процедуре ПередЗаписью первое условие работает, а второе нет

Версия для печатиPDF-версия
В Процедуре ПередЗаписью первое условие работает, а второе нет:
 
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    Если Объект.ЗаявкаТ <> Истина И Не ЗначениеЗаполнено(Объект.ДатаО) Тогда
        Сообщить ("Не заполнено поле Дата окончания тендера", СтатусСообщения.Важное);
        Отказ = Истина;
        Возврат;
    КонецЕсли;
        Сообщить (Объект.Результат, СтатусСообщения.Важное);
    Если Объект.Результат = "Отменить" И Не ЗначениеЗаполнено(Объект.ПричинаО) Тогда
        Сообщить ("Не заполнено поле Причина отказа", СтатусСообщения.Важное);
        Отказ = Истина;
        Возврат;
    КонецЕсли;
КонецПроцедуры
 
При чем строка
        Сообщить (Объект.Результат, СтатусСообщения.Важное);
работает и слово "Отменить" выводит.
 
Возможно дело в Объект.Результат = "Отменить"  ?
реквизит Результат в форме выбирается из справочника Результат (наименование). 
Значение "Отменить" там есть, может синтаксис?

Если Объект.Результат выбирается из справочника, то при сравнении со строкой "Отменить" всегда будет Ложь. Попробуйте привести Объект.Результат к строке:

Если Строка(Объект.Результат) = "Отменить" ...

Большое спасибо! Заработало всё