Управляемые формы

Версия для печатиPDF-версия

Платформа:

Нужно создать обработку которая из ексель будет подгружать номенклатуру. Как сделать это через управляемые формы чтобы на форме обработки отобразилось то что мы будем подгружать с возможностью выбора недостающих реквизитов.Само прочение ексель файла и интерактивное сздание элементов сделала а как быть с формой. Подскажите?
 

 

 

Добавить на форму таблицу. При чтении из excel её заполнять. Потом вручную заполнить то, чего не хватает. Затем обработать получившуюся таблицу.

Как работаь с таблицейзначений. Добавить колонки. Добавлять строку. Сортировать и в цикле перебирать значения строки.

Тут ничего сложного нет. Вся информация есть в синтакс-помощнике.

Следует только иметь в виду, что реквизит формы Таблица значений на самом деле имеет тип ДанныеФормыКоллекция. Соответственно, его свойства и методы будут немного отличаться от свойств и методов объекта ТаблицаЗначений.

И ещё, в чистом виде Таблица значений существует только на сервере. На клиенте таблица значений не доступна.

И еще пдскажитепожалуйста как в 8ке прицепить вешние печатные формы к кнопке документа.
 

В этой теме посмотрите.

Делаю вешнюю обработку в 8.3 бухгалтерия. Когда запускаю не выводит реквизиты на форме в видимсть и как посавить на форму таблицу если форма вконфигураторе не меняет свой размер.

 И на форме нет кнопки сформировать. Кнопку добавлять?

Реквизиты и таблицу значений на форму перетащили?

В управляемом приложении кнопки не существуют сами по себе. Сначала надо создать команду, а потом перетащить её на форму. При этом автоматически создастся кнопка.

Реквизиты сами встали пи создании формы. А таблицу значений не могу не дает менять размр формы. Где создаються команды? Создала кнопку программно действие идет только если процедура наклиенте, а так ругаеться на работу с таблицей значений. пишет тип не определен.

 

Что-то случилось с сайтом - не могу картинку загрузить.

Что значит "Реквизиты сами встали при создании формы"? Речь о реквизитах формы или реквизитах обработки?

Команды добавляются в правой верхней области окна редактирования формы (там же где и реквизиты). Нужно только перейти на соответствующую вкладку. Обработка команды всегда происходит на клиенте.

А откуда берётся таблица значений? Вы её программно создаёте? Если да, то, как я уже писал, на клиенте такой тип не суцществует. Поэтому я и предложил использовать таблицу формы. Она существует и на клиенте и на сервере. 

Выложите кусок кода, с которым есть проблемы.

Сайт починили.

Сначала создаёте реквизиты и таблицу формы:

Создание реквизитов формы

Потом перетаскиваете их на форму:

Перетаскивание реквизитов на форму

Создаёте команду формы, устанавливаете ей обработчик:

Создание команды формы

Перетаскиваете команду на форму:

Перетаскивание команды на форму

Зелёным обведены результаты изменений на форме, которые платформа производит автоматически.

При перетаскивании возникают проблемы мжно перетащить с помщью каких либо кнопок или сочетания клавиш.
 

С перетаскивнием разобралась. Код выдает ошибки.
КоличстовСтрок=Ексель.Cells(1,1).SpecialCells(11).Row;

выдает ошибку.Произошла исключтельная стуация. И при чтении значений ячеек тоже.

 

А к экселю подключается и лист открывает?

Посмотрите, что в переменной Ексель в этот момент находится.

Уже в переменной ексель содержиться ошибка и исключительная ситуация.

Подключение к эксель в Попытке организовано?

С экселем разобралась. Друое выдает ошибку переменная сравочник не определена.
 &НаКлиенте

Процедура Нажатие()

Спр=Справочники.номенклатура;

...

КонецПроцедуры;

К менеджерам справочников, как и документов, можно обращаться только на сервере.

На клиенте новую номенклатуру создать нельзя.

пишу
& Насервере

Функция возврат()

 Спр=Справочники.Номенклатура;

КонецФункции
& Наклиенте

Процедура Создание()

 Спр1=Возврат();

КонецПроцедуры

при запуске выдает ошибку
Отсутствует отображение для типа справочникменеджер.Номенклатура

Так я же только что писал, что на клиенте доступа к менеджерам справочников нет.

В общем алгоритм создания номенклатуры такой: формируете на клиенте структуру реквизитов, отправляете её на сервер, создаёте на сервере новый элемент и, если нужно, возвращаете ссылку нового элемента на клиента.

это сделала. Подскажите как установить новый код элементу поцедура УстановитьНовыйКод() не работает.

С кодом тоже разобралась. Как программно получить строку таблицы.
Делаю Таб.Получить(Сч) на последнем значении счетчика выдает ошибку недопустимое значние.
 

Нумерация строк в таблице начинается с 0. Чтобы добраться до десятой строки, нужно делать Таб.Получить(9).

Есть обработка в ней две формы одна на обычном приложении работает, вторая на управляемом, как сделать чтобы запускалась и там и там. Надо перевести данную обработку чтобы работала как на обычных приложений так и на управляемых

Попробуйте на вкладке "Формы" - "Основные" выбрать в качестве формы обработки управляемую форму, а на вкладке "Формы" - "Дополнительные" - обычную форму. По идее, должна запускаться соответствующая форма в зависимости от типа запуска приложения.

Не дает править дополнительные для выбора формы, просто пустое значение.

Попробуйте открыть обработку в конфигурации на обычных формах (например, Управление торговлей 10.3). Там должно быть доступно редактирование.

Спасибо получилось.