Уникальность и заполненность значения элемента формы

Версия для печатиPDF-версия

Платформа:

Здравствуйте! Мне нужно поставить ограничение в табличную часть справочника. Я пишу в поле ввода таблице процедура при изменении

//Татьяна
Для каждого стр из мПериод Цикл
Если Формат(стр.Начало,"ДФ=dd/MM")=Формат(Элемент.Значение,"ДФ=dd/MM") Тогда
Предупреждение("Значение не уникально!!!");
Отказ=Истина;
КонецЕсли;
КонецЦикла;
Если ЗначениеЗаполнено(Элемент.Значение)=Ложь тогда
Предупреждение("Значение не заполнено!!!");
отказ=истина;
КонецЕсли;
 Он при проверке похоже видит сам себя и когда делаешь копированием то есть когда значение просто выделаяеться а не вводиться не работает.
 
 

А что такое мПериод и что за Элемент?

Попробуйте привязать проверку к событию ПередОкончаниемРедактирования табличного поля.