Создание документа на основании существующего

Версия для печатиPDF-версия

Платформа:

Сам текст модуля:

&НаКлиенте
Процедура ВводНаОснованииНаКлиенте(Команда)
СсылкаНаДокумент = ВводНаОснованииНаСервере();
    ОткрытьЗначение(СсылкаНаДокумент);
КонецПроцедуры
 
&НаСервере
Функция ВводНаОснованииНаСервере()
//Создание по табличной части №1
Если Объект.ТЧПос1.Количество()>0 Тогда
ДокументПТиУ = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();
        ДокументПТиУ.Дата        = Объект.Дата;
ДокументПТиУ.Партнер     = Объект.Партнер_1;
ДокументПТиУ.Контрагент  = Объект.Контрагент_1;
ДокументПТиУ.Организация = Объект.Организация;
ДокументПТиУ.Склад       = Объект.Склад;
ДокументПТиУ.Валюта      = Константы.ВалютаРегламентированногоУчета;
ДокументПТиУ.ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ЗакупкаУПоставщика;
ДокументПТиУ.ВалютаВзаиморасчетов  = Константы.ВалютаРегламентированногоУчета;
ДокументПТиУ.Комментарий = "Валютный курс на дату поступления: " + Объект.КурсУЕОбщий1;
ДокументПТиУ.СуммаВзаиморасчетов = Объект.ТЧПос1.Итог("СуммаР_Итог");
 
НоваяСтрока = ДокументПТиУ.Товары.Добавить();
НоваяСтрока.Номенклатура = Объект.ТЧПос1.Номенклатура;
НоваяСтрока.Упаковка     = Объект.ТЧПос1.Номенклатура.ЕдиницаИзмерения;
НоваяСтрока.Количество   = Объект.ТЧПос1.Количество();
НоваяСтрока.Цена         = Объект.ТЧПос1.ЦенаР_Итог;
НоваяСтрока.Сумма        = Объект.ТЧПос1.СуммаР_Итог;
ДокументПТиУ.Записать();
Возврат ДокументПТиУ.Ссылка;
Иначе
 
КонецЕсли;
 
КонецФункции

Шапку создает, а вот табличную часть нет - говорит, что не найдена номенклатура...

{Документ.ДокументINVOICES.Форма.ФормаДокумента.Форма(414)}: Поле объекта не обнаружено (Номенклатура)
НоваяСтрока.Номенклатура = Объект.ТЧПос1.Номенклатура;
 
 
Цикл пропустил:
Вот так счас, но что-то упустил:
Для Каждого Элемент Из Объект.ТЧПос1 Цикл
        НоваяСтрока = ДокументПТиУ.Товары.Добавить();
        НоваяСтрока.Номенклатура = Объект.ТЧПос1.Номенклатура;
        НоваяСтрока.Упаковка         = Объект.ТЧПос1.Номенклатура.ЕдиницаИзмерения;
        НоваяСтрока.Количество    = Объект.ТЧПос1.Количество;
        НоваяСтрока.Цена                = Объект.ТЧПос1.ЦенаР_Итог;
        НоваяСтрока.Сумма             = Объект.ТЧПос1.СуммаР_Итог;
КонецЦикла;
 

Лопух))))  Вот так надо было

Для Каждого Элемент Из Объект.ТЧПос1 Цикл
        НоваяСтрока = ДокументПТиУ.Товары.Добавить();
        НоваяСтрока.Номенклатура = Элемент .Номенклатура;
        НоваяСтрока.Упаковка         = Элемент .Номенклатура.ЕдиницаИзмерения;
        НоваяСтрока.Количество    = Элемент Количество;
        НоваяСтрока.Цена                = Элемент .ЦенаР_Итог;
        НоваяСтрока.Сумма             = Элемент .СуммаР_Итог;
КонецЦикла;
 
 

Я так понимаю, что вопрос уже снят?

Да, просто пережитки 7.7 :) Пока еще привыкаю)