Работа в тонком и толстом клиенте

Версия для печатиPDF-версия

Платформа:

Добрый день.

Подскажите, пожалуйста, если я работаю в толстом клиенте, то на форме картинка отображается, а если в тонком, то нет. Как исправить эту ошибку? В отладке в тонком клиенте на функцию даже не переходит. Модуль прилагаю

&НаКлиенте
Процедура ТоварыПриАктивизацииСтроки(Элемент)
Если Объект.Товары.Количество()>0 Тогда 
ТекущиеДанныеСписка = Элементы.Товары.ТекущиеДанные;
Попытка 
АдресКартинки = НавигационнаяСсылкаКартинки(ТекущиеДанныеСписка.Номенклатура.ФайлКартинки, УникальныйИдентификатор);
Исключение
АдресКартинки = "";         
КонецПопытки;
КонецЕсли;
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция НавигационнаяСсылкаКартинки(ФайлКартинки, ИдентификаторФормы)
 
УстановитьПривилегированныйРежим(Истина);
 
Попытка
АдресКартинки = ПрисоединенныеФайлы.ПолучитьДанныеФайла(ФайлКартинки, ИдентификаторФормы).СсылкаНаДвоичныеДанныеФайла;
Исключение
//ОбщегоНазначенияКлиентСервер.СообщитьПользователю(КраткоеПредставлениеОшибки(ИнформацияОбОшибке()));
АдресКартинки = "";
КонецПопытки;
 
Возврат АдресКартинки;
 
КонецФункции
 

Во-первых, вставьте в ветку Исключение вывод информации об ошибке (хотя бы "Сообщить(ОписаниеОшибки());").

Во-вторых, в тонком кленте невозможно получить значение реквизита из ссылки на объект. Т.е. ошибка происходит в этом месте "ТекущиеДанныеСписка.Номенклатура.ФайлКартинки". Нужно получать значение реквизита ФайлКартинки на сервере либо в функцию НавигационнаяСсылкаКартинки передавать не ФайлКартинки, а Номенклатуру.

В тонком клиенте не заходит в функцию НавигационнаяСсылкаКартинки, т.к. ошибка происходит до её вызова.

Спасибо, всё по полочкам разложили )) Попробую.

Всё получилось! Спасибо. Сделала функцию на сервере получение файла картинки.