Процедура выбора файла

Версия для печатиPDF-версия

Платформа:

&НаКлиенте
Процедура ПутьОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
ПутьОбработкаВыбораНаСервере();
КонецПроцедуры
 
&НаСервереБезКонтекста
Процедура ПутьОбработкаВыбораНаСервере()
 
Режим                                  = РежимДиалогаВыбораФайла.Сохранение;
ДиалогОткрытияФайла                    = Новый ДиалогВыбораФайла(Режим);
ДиалогОткрытияФайла.ПолноеИмяФайла     = "";
Фильтр                                 = НСтр("ru = 'Текст'; en = 'Text'")+ "(*.txt)|*.txt";
ДиалогОткрытияФайла.Фильтр             = Фильтр;
ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
ДиалогОткрытияФайла.Заголовок          = "Выберите файл";
 
Если ДиалогОткрытияФайла.Выбрать() Тогда
МассивФайлов = ДиалогОткрытияФайла.ВыбранныеФайлы;
Для Каждого ИмяФайла Из МассивФайлов Цикл
ВыбФайл = Новый Файл(ИмяФайла);
КонецЦикла;
Иначе
Предупреждение(НСтр("ru = 'Файл(ы) не выбран!'; en = 'File(s) not selected!'"));
КонецЕсли;
 
КонецПроцедуры
 
err: {ВнешняяОбработка.ВыгрузкаИнвойсов.Форма.Форма.Форма(335,49)}: Тип не определен (ДиалогВыбораФайла)
ДиалогОткрытияФайла                    = Новый <<?>>ДиалогВыбораФайла(Режим); (Проверка: Сервер)
 
Почему - не могу понять (
реквизиты на форме - Путь (безразмерная строка)
ссылка на документ для выгрузки

 

Разобрался сам) Нельзя диалог открытия на сервере - только на клиенте :)

Кстати, и Предупреждение на сервере тоже нет.

А с какой целью вообще была создана серверная процедура?

Конфигуратор предложил создать) По нажатию кнопки - мол на Клиенте и на СервереБезКонтекста