Помогите пожалуйста!!!!!

Версия для печатиPDF-версия

Платформа:

Помогите Пожалуйста с выполнением заданния!!

хочу поступить на курсы программирования 1С, но для этого нужно выполнить задание.

бОльшую часть задания я выполнил осталось только это:

 Документ «СчетКлиенту»

Создать документ «СчетКлиенту», который  можна вводить на основанни документа «НарядНаРаботы».

В документ добавить реквизиты: Клиент, Основание(документ «НарядНаРаботы»). Создать табличну частину «РаботыУслуги», с реквизитами «Номенклатура», «Количество», «Цена», «Сумма».

При вводе документа на основании «НарядНаРаботы» табличную часть «РаботыУслуги» заполнить строками, где установлена галочка в реквізите «ВыставлятьВСчет».

Если есть добрые люди))))помогите сделать))))

Создаёте документ СчетКлиенту. На вкладке "Ввод на основании" в поле "Вводится на основании" добавляете Документ.НарядНаРаботы.

Вкладка "Ввод на основании"

Нажимаете кнопку "Конструктор ввода на основании" и заполняете соответствующие выражения.

Конструктор ввода на основании

Нажимаете на кнопку "ОК" и переходите в модуль объекта документа СчетКлиенту.

В процедуре ОбработкаЗаполнения нужно добавить условие на отбор строк:


Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
	//{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
	// Данный фрагмент построен конструктором.
	// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
	Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.НарядНаРаботы") Тогда
		// Заполнение шапки
		Клиент = ДанныеЗаполнения.Клиент;
		Основание = ДанныеЗаполнения.Ссылка;
		Для Каждого ТекСтрокаРаботыУслуги Из ДанныеЗаполнения.РаботыУслуги Цикл
			
			Если ТекСтрокаРаботыУслуги.ВыставлятьВСчет Тогда // Добавленное условие !!!
				НоваяСтрока = РаботыУслуги.Добавить();
				НоваяСтрока.Количество = ТекСтрокаРаботыУслуги.Количество;
				НоваяСтрока.Номенклатура = ТекСтрокаРаботыУслуги.Номенклатура;
				НоваяСтрока.Сумма = ТекСтрокаРаботыУслуги.Сумма;
				НоваяСтрока.Цена = ТекСтрокаРаботыУслуги.Цена;
				
			КонецЕсли;
			
		КонецЦикла;
	КонецЕсли;
	//}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ
КонецПроцедуры

Спасибо большое)))