Получение данных из строки

Версия для печатиPDF-версия

Платформа:

Как вычленить адрес из строки напр. Основной (ул. Попова, 258Д) с помощью строковых функций.

Шаблон строки всегда один? Сначала текст, потом адрес в скобках?

Да. Попробовала функцией стрразделить(..., "(,)") ошибку выдает Указанная функция не определена при проверке еще.

Что то типа

длина=стрдлина(спр.наименование);
Для Сч=1 по Длина Цикл
стр=прав(спр.наименование,длина-сч);
Если СтрНачинаетьсяС(стр,"(") тогда
сообщить(стр);
прервать;
КонецЕсли;
 
КонецЦикла;
не принимает СтрНачинаетьсяС почему то, попробую вместо написать Лев(стр,1)="("

Как-то так:

СтрокаАдреса = Сред(СтрокаАдреса, Найти(СтрокаАдреса, "("));

СтрокаАдреса = Лев(СтрокаАдреса, СтрДлина(СтрокаАдреса) - 1);

Спасибо! Еще вопросик маленькиий. Как выделить жирным строку таблич. части при установке одного из значений основным.

Перем мЖирныйШрифт;
Процедура КоманднаяПанельВидыДеятельностиСделатьОсновным(Кнопка)
 
Если ЭлементыФормы.Пдчиненные.ТекущиеДанные = Неопределено Тогда
Возврат;
КонецЕсли; 
 
Если НЕ ЗначениеЗаполнено(ЭлементыФормы.Пдчиненные.ТекущиеДанные.Склад) Тогда
Возврат;
КонецЕсли;
 
Основной= ЭлементыФормы.Пдчиненные.ТекущиеДанные.Склад;
ЭлементыФормы.Пдчиненные.ОформлениеСтроки(?).Шрифт = мЖирныйШрифт;
 
КонецПроцедуры
мЖирныйШрифт = Новый Шрифт(,, Истина);
 
 

или прописываю процедуру как в стандарте

 

Процедура ПодчиненныеПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
 
    Если ЗначениеЗаполнено(ДанныеСтроки.Ссылка) И ЭтотОбъект.Основной = ДанныеСтроки.Ссылка Тогда
        ОформлениеСтроки.Шрифт = мЖирныйШрифт;
    КонецЕсли;
 
КонецПроцедуры
мЖирныйШрифт = Новый Шрифт(,, Истина);

она не срабатывает.

А если ДанныеСтроки.Ссылка заменить на ДанныеСтроки.Склад и ЭтотОбъект убрать?

Неа. Почему то в нее не обращаеться.

В кого "в неё"?

в процедуру. Я точку останова ставила.

Проверьте, назначена ли процедура в качестве обработчика события.

Спасибо! Заработала.

Есть справочник группа складов, там один основной и несколько подчиненных. Например если находяться в одном здании то брать общий остаток. 
Как в запросе взять общий остаток если склад входит в группу.
ВЫБРАТЬ 

    Товары.Номенклатура,

   Товары.КоличествоОстаток 
ИЗ 

    РегистрНакопления.ТоварыОрганизаций.Остатки(
        &Дата,
        Номенклатура = &Номенклатура
            И Склад = &Склад) КАК Товары

Что-то обсуждение совсем далеко ушло от первоначальной темы. Создал новую тему.