Подвал для программно созданной колонки в табличной части документа

Версия для печатиPDF-версия
Добрый день. Прошу помощи. Пытаюсь добавить подвал с итогом по табличной части программно созданных колонок. Ругается "Недопустимое значение". Не могу понять в чем причина
#Область Формирование_сетки_распределения_товаров_с_заполнением_ее_товарами
&НаСервере
Процедура СоздатьДинамическуюКолонку(ИмяКолонки)
	нРеквизиты = Новый Массив;
	нРеквизиты.Добавить(Новый РеквизитФормы(ИмяКолонки,Новый ОписаниеТипов("Число"),"Объект.Товары"));
	нРеквизиты.Добавить(Новый РеквизитФормы("Итог"+ИмяКолонки,Новый ОписаниеТипов("Число"),"Объект.Товары"));
	
	ИзменитьРеквизиты(нРеквизиты);
	
	нЭлемент     = Элементы.Добавить(ИмяКолонки, Тип("ПолеФормы"),Элементы.Товары);
	нЭлемент.Вид = ВидПоляФормы.ПолеВвода;
	нЭлемент.ПутьКДанным        = "Объект.Товары."     + ИмяКолонки;
	нЭлемент.ПутьКДаннымПодвала = "Объект.Товары.Итог" + ИмяКолонки;
	нЭлемент.УстановитьДействие("ПриИзменении","ОбработчикПриИзмененииКолонкиКоличества");
	ДобавленныеЭлементы.Добавить(нРеквизиты.Имя);
КонецПроцедуры


&НаСервере
Процедура СформироватьСеткуНаСервере()
	Если Объект.СписокИнвойсов.Количество()<1 Тогда
		Сообщить("Список документов для формирования сетки пуст! Формирование сетки невозможно!");
		Возврат;
	КонецЕсли;
	
	Если ДобавленныеЭлементы.Количество()>0 Тогда
		Для Каждого ДобЭлемент Из ДобавленныеЭлементы Цикл 
			Элементы.Удалить(Элементы[ДобЭлемент.Значение]);
		КонецЦикла;
		ДобавленныеЭлементы.Очистить();
	КонецЕсли;
	
	Если ДобавленныеРеквизиты.Количество()>0 Тогда  
		ИзменитьРеквизиты(,ДобавленныеРеквизиты.ВыгрузитьЗначения());
		ДобавленныеРеквизиты.Очистить();
	КонецЕсли;
	
	Для Каждого Стр Из Объект.СписокСкладов Цикл 
		ИндМагазина = Стр.Склад.ДополнительныеРеквизиты[0].Значение;
		ИмяСклада   = Стр.Склад.Наименование;
		СоздатьДинамическуюКолонку(ИндМагазина);
		ДобавленныеРеквизиты.Добавить("Объект.Товары." + ИндМагазина);
	КонецЦикла;
	
	Для Каждого Стр1 Из Объект.СписокКонтрагентов Цикл
		ИндПартнера = Стр1.Партнер.ДополнительныеРеквизиты[0].Значение;
		ИмяПартнера = Стр1.Партнер.Наименование;
		СоздатьДинамическуюКолонку(ИндПартнера);
		ДобавленныеРеквизиты.Добавить("Объект.Товары." + ИндПартнера);
	КонецЦикла;
	
КонецПроцедуры

&НаКлиенте
Процедура ОбработчикПриИзмененииКолонкиКоличества(Элемент)
	ТД      = Элементы.Товары.ТекущиеДанные;
	Сверка  = ТД.Количество;
	Сток    = ТД.КоличествоСток;
	СверкаР = Сверка + Сток;
	Для Сч = 1 По ДобавленныеРеквизиты.Количество() Цикл 
		ИмяРеквизита = СтрЗаменить(ДобавленныеРеквизиты[Сч-1].Значение,"Объект.Товары.","");
		СверкаР      = СверкаР - ТД[ИмяРеквизита];
		ЭтаФорма["Итог"+ИмяРеквизита] = ТД.Итог(ИмяРеквизита);
	КонецЦикла;
	ТД.КоличествоСверка = СверкаР;
	Если Элементы.Товары.ТекущиеДанные.КоличествоСверка<0 Тогда
		ЦветПоляТаблицы = Новый Цвет (255,0,0);
		Элементы.Товары.ТекущийЭлемент.ЦветФона = ЦветПоляТаблицы;
		Сообщить("Данные в поле 'Количество для сверки' не могут быть отрицательным числом");
		Возврат 
	Иначе
		ЦветПоляТаблицы = Новый Цвет (0,255,0);
		Элементы.Товары.ТекущийЭлемент.ЦветФона = ЦветПоляТаблицы;
	КонецЕсли;
КонецПроцедуры
Подскажите пожалуйста, где ошибся?