Подбор

Версия для печатиPDF-версия

Платформа:

ДД! Есть обработка в ней таблица Сотрудники. Есть кнопка "подбор" командой даю процедуру
ОткрытьФорму("Справочник.сотрудник.формавыбора"); Форма открываеться, а парметры не передаються выбранные? Как сделать?

Надо обработку выбора для таблицы Сотрудники прописать. Это обработчик события.

Вот примерный код:

&НаКлиенте
Процедура Подбор(Команда)
	ОткрытьФорму("Справочник.Сотрудники.ФормаВыбора",, Элементы.Сотрудники);
КонецПроцедуры

&НаКлиенте
Процедура СотрудникиОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
	Если ЗначениеЗаполнено(ВыбранноеЗначение) Тогда 
		НоваяСтрока = Объект.Сотрудники.Добавить();
		НоваяСтрока.Сотрудник = ВыбранноеЗначение;
	КонецЕсли;
КонецПроцедуры

Почему то при множественном выборе добавляет пустую строку. Обработочку прикрепила.

Прикреплённые файлы: 

При множественном выборе ВыбранноеЗначение имеет тип Массив. Нужно обход массива делать.

Ага, спасибо. Сделала уже. Все встало.