Переменные в модуле формы

Версия для печатиPDF-версия

Платформа:

Помогите понять с описанием перемнных в данном случае Перем Штрих должна быть глобальной в модуле формы

ошибка

{Обработка.Штрихануть.Форма.Форма.Форма(35,24)}: Переменная не определена (штрих)
 Этаформа.Объект.инфа= <<?>>штрих; (Проверка: Тонкий клиент)
{Обработка.Штрихануть.Форма.Форма.Форма(36,15)}: Переменная не определена (штрих)
    Сообщить (<<?>>штрих);  (Проверка: Тонкий клиент)
 

код 

&НаКлиенте
Перем переключатель;
Перем штрих;   здесь я определил ее !!!!!!!!!!!!!!!
&НаКлиенте
 
Процедура Вручную(Команда)
   ..............
 КонецПроцедуры
 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
 переключатель="сканер";
 Штрих="";                                  здесь инициализация переменных при открытии формы!!!
 Сообщить ("Приоткрытии я сработала!!!!");
 Сообщить ("Инициализация переменных-- "+переключатель+ "---"+ штрих);
КонецПроцедуры
 
&НаКлиенте
 Процедура Искать(Команда)
 
    Сообщить (штрих);                          Если здесь закомментировать , то сглатывает без ошибки , но и не срабатывает !
КонецПроцедуры
 
дальше и не стал писать код, т.к. изначально не вижу перменной Штрих после инициализации !!!!
 

 

Добавьте реквизит формы нужного типа и не мучайтесь.

Надо добавить директиву &НаКлиенте непосредственно перед объявлением переменной "штрих". Иначе она объявляется на сервере. Т.е. надо написать так:

&НаКлиенте
Перем переключатель;
&НаКлиенте
Перем штрих;