Переключатели и формы

Версия для печатиPDF-версия

Платформа:

Здравствуйте. Подскажите пожалуйста, как сделать так чтобы при переключении , оставались поля нужные для вычисления данной геометрической фигуры? Искал , не могу найти, где привязать переключатель к конкретному полю (полям).

Я создал все это в форме, т.е. реквизит формы, не через объект.

Сделайте для каждой фигуры отдельную группу полей (реквизитов формы). В обработчике события ПриИзменении у переключателя сделайте управление видимостью групп полей.

Спасибо за ответ. Если можете помогите разобаться. Вот моя база. Толком не понимаю как это сделать.Как управлять видимостью полей или групп.  Посмотрите пожалуйста, что-то совсем запутался. Может примеры где есть?

 

Код типа:

 

&НаКлиенте
Процедура ФигураПриИзменении(Элемент)
    

    Квадрат= Истина;
    Если Квадрат=Истина Тогда
    СторонаКвадрата = Истина;
    Иначе
    СторонаКвадрата = Ложь;  
  

 

 КонецЕсли;

КонецПроцедуры
 

 

 

Прикреплённые файлы: 

В конфигураторе снимаете флажок Видимость у всех групп.

Обработчик события ПриИзменении у Фигуры будет такой:

&НаКлиенте
Процедура ФигураПриИзменении(Элемент)
	Элементы.ПлощадьКвадрата.Видимость = Фигура = "Квадрат";
	Элементы.ПлощадьКруга.Видимость = Фигура = "Круг";
	Элементы.ПлощадьПрямоугольника.Видимость = Фигура = "Прямоугольник";
	Элементы.ПлощадьТреугольника.Видимость = Фигура = "Треугольник";
КонецПроцедуры
Прикреплённые файлы: 

Спасибо большое за помощь, получилось. Не первый раз откликаетесь и помогаете, без вашей помощи долого бы разбирался. Спасибо еще раз!