Переделка акта с бух.8.2 на бух.8.3

Версия для печатиPDF-версия

Платформа:

Здравствуйте. Возникла проблема с печатной формой. Эта форма изначально прописана на бух.8.2, но она также необходима и для работы в бух.8.3. Сама попробовала что-либо найти и изменить в макете, но не получилось. Возможно ли исправить? Прилагаю весь код акта, скрины. Помогите пожалуйста решить проблему. (Я не программист, а обычный бухгалтер и в этом ничего не смыслю, но может общими усилиями, я и смогу наладить). Спасибо.

#Если Клиент Тогда
	Функция глРазложить(Знач Стр, Разделитель = ",") Экспорт
		СЗ = Новый СписокЗначений;
		Если Разделитель = " " Тогда
			Стр = СокрЛП(Стр);
			Пока 1=1 Цикл
				Поз = Найти(Стр,Разделитель);
				Если Поз=0 Тогда
					СЗ.Добавить(Стр);
					Возврат СЗ;
				КонецЕсли;
				СЗ.Добавить(Лев(Стр,Поз-1));
				Стр = СокрЛ(Сред(Стр,Поз));
			КонецЦикла;
		Иначе
			ДлинаРазделителя = СтрДлина(Разделитель);
			Пока 1=1 Цикл
				Поз = Найти(Стр,Разделитель);
				Если Поз=0 Тогда
					СЗ.Добавить(Стр);
					Возврат СЗ;
				КонецЕсли;
				СЗ.Добавить(Лев(Стр,Поз-1));
				Стр = Сред(Стр,Поз+ДлинаРазделителя);
			КонецЦикла;
		КонецЕсли;
	КонецФункции 
	
	Функция РазборФИО(Сотрудник)
		ФИО = глРазложить(Сотрудник," ");
		Фамилия = ""; Имя = ""; Отчество = "";
		Если ФИО.Количество() > 0 Тогда
			Фамилия = Строка(ФИО.Получить(0));
			Если ФИО.Количество() > 1 Тогда
				Имя		= Строка(ФИО.Получить(1));
				Если ФИО.Количество() > 2 Тогда 
					// а вот отчество бывает и не из одного слова				
					Для Сч = 2 По ФИО.Количество()-1 Цикл
						Отчество = Отчество + Строка(ФИО.Получить(Сч)) + " ";
					КонецЦикла;
					Если ЗначениеЗаполнено(Отчество) Тогда  
						Отчество = Лев(Отчество,СтрДлина(Отчество)-1);
					КонецЕсли;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
		Возврат Фамилия+?(ЗначениеЗаполнено(Имя)," "+Лев(Имя,1)+"."+?(ЗначениеЗаполнено(Отчество),Лев(Отчество,1)+".",""),"")
	КонецФункции
	
	Функция ЕдиницаИзмеренияНоменклатуры(Объект)
		
		Возврат Объект.БазоваяЕдиницаИзмерения;
		
	КонецФункции
	
	Функция ПолучитьПодразделениеПоСотруднику(СсылкаНаФизЛицо)
		Подразделение = Неопределено;
		Запрос = Новый Запрос();
		Запрос.УстановитьПараметр("Сотрудник",СсылкаНаФизЛицо);
		Запрос.Текст = "Выбрать Первые 1
		|Сотрудник.ТекущееПодразделениеОрганизации Как Подразделение
		|Из
		|Справочник.СотрудникиОрганизаций Как Сотрудник
		|Где 
		|Сотрудник.Физлицо = &Сотрудник";
		РезультатЗапроса = Запрос.Выполнить().Выгрузить();
		Если  РезультатЗапроса.Количество() Тогда
			Подразделение = РезультатЗапроса[0].Подразделение;
		КонецЕсли;
		Возврат Подразделение;
	КонецФункции
	
	Функция ПолучитьДолжностьСотрудника(СсылкаНаФизЛицо)
		Должность = Неопределено;
		Запрос = Новый Запрос();
		Запрос.УстановитьПараметр("Сотрудник",СсылкаНаФизЛицо);
		Запрос.Текст = "Выбрать Первые 1
		|Сотрудник.ТекущаяДолжностьОрганизации Как Должность
		|Из
		|Справочник.СотрудникиОрганизаций Как Сотрудник
		|Где 
		|Сотрудник.Физлицо = &Сотрудник";
		РезультатЗапроса = Запрос.Выполнить().Выгрузить();
		Если  РезультатЗапроса.Количество() Тогда
			Должность = РезультатЗапроса[0].Должность;
		КонецЕсли;
		Возврат Должность;
	КонецФункции
	
	Функция ИнвентарныйНомерНоменклатуры(Объект)
		Возврат Объект.Код;	
	КонецФункции
	
	Функция ДатаПриемаСотрудникаНаРаботу(СсылкаНаФизЛицо)
		ДатаПриема = Неопределено;
		Запрос = Новый Запрос();
		Запрос.УстановитьПараметр("Сотрудник",СсылкаНаФизЛицо);
		Запрос.Текст = "Выбрать Первые 1
		|Сотрудник.ДатаПриемаНаРаботу Как ДатаПриема
		|Из
		|Справочник.СотрудникиОрганизаций Как Сотрудник
		|Где 
		|Сотрудник.Физлицо = &Сотрудник";
		РезультатЗапроса = Запрос.Выполнить().Выгрузить();
		Если  РезультатЗапроса.Количество() Тогда
			ДатаПриема = РезультатЗапроса[0].ДатаПриема;
		КонецЕсли;
		Возврат ДатаПриема;   
	КонецФункции
	
	Функция ПечатьАктаОПриемеПередачеМатериальныхЦенностей()
		Запрос = Новый Запрос();
		Запрос.УстановитьПараметр("ТекущийДокумент",СсылкаНаОбъект);
		Запрос.Текст = "Выбрать
		|ПередачаМатериаловВЭксплуатацию.Номенклатура Как Номенклатура,
		|ПередачаМатериаловВЭксплуатацию.Количество Как Количество,
		|ПередачаМатериаловВЭксплуатацию.ФизЛицо Как ФизЛицо
		|Из
		|Документ.ПередачаМатериаловВЭксплуатацию.ИнвентарьИХозяйственныеПринадлежности 
		|Как
		|ПередачаМатериаловВЭксплуатацию
		|Где
		|ПередачаМатериаловВЭксплуатацию.Ссылка = &ТекущийДокумент";
		
		ТабличнаяЧасть = Запрос.Выполнить().Выгрузить();
		Если НЕ ТабличнаяЧасть.Количество() Тогда
			Предупреждение("Табличная часть ""Инвентарь и хозяйственные принадлежности"" пустая!" + Символы.ПС +
			"Заполните табличную часть, проведите документ и повторите попытку.",10,"Предупреждение");
			Отказ = Истина;
			Возврат Неопределено;
		КонецЕсли;
		
		Если СсылкаНаОбъект.ПометкаУдаления Тогда
		 Сообщить("Печать документа, помеченного на удаление, невозможна!",СтатусСообщения.Внимание);
		 Возврат Неопределено;
	
		КонецЕсли;

		Если НЕ СсылкаНаОбъект.Проведен Тогда
		 Сообщить("Печать непроведенного документа невозможна!",СтатусСообщения.Внимание);
		 Возврат Неопределено;
	    КонецЕсли;
		
		ТабДокумент = Новый ТабличныйДокумент;
		Если НЕ ТабДокумент.АвтоМасштаб Тогда
			ТабДокумент.АвтоМасштаб = Истина;
		КонецЕсли;
		ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ПередачаМатериаловВЭксплуатацию_Акт";
		Макет = ПолучитьМакет("Акт");
		ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
		ОбластьМакета.Параметры.Организация = СсылкаНаОбъект.Организация;
		
		Сотрудник = ТабличнаяЧасть[0].ФизЛицо.Ссылка;
		
		Подразделение = ПолучитьПодразделениеПоСотруднику(Сотрудник); 
		ОбластьМакета.Параметры.СтруктурноеПодразделение = ?(Подразделение <> Неопределено,Подразделение,"<не задано>");
		ОбластьМакета.Параметры.Сотрудник = Сотрудник.Наименование;
		Должность = ПолучитьДолжностьСотрудника(Сотрудник);
		ОбластьМакета.Параметры.Должность = ?(Должность <> Неопределено, Должность, "<не указана>");
		ДатаПриемаНаРаботу = ДатаПриемаСотрудникаНаРаботу(Сотрудник);
		ОбластьМакета.Параметры.ДоговорДата = ?(ДатаПриемаНаРаботу <> Неопределено,
		                                        Формат(ДатаПриемаНаРаботу,"ДФ=dd.MM.yyyy"), "<не указана>");
		ОбластьМакета.Параметры.ДатаСоставления = Формат(СсылкаНаОбъект.Дата, "ДФ=dd.MM.yyyy");
		ТабДокумент.Вывести(ОбластьМакета);
		ОбластьСтроки = Макет.ПолучитьОбласть("Строка");
		
		НомерСтроки = 0;
		
		Для Каждого СтрокаТЧ Из ТабличнаяЧасть Цикл
			НомерСтроки = НомерСтроки + 1;
			ОбластьСтроки.Параметры.Номер = НомерСтроки;
			ОбластьСтроки.Параметры.Номенклатура = СокрЛП(СтрокаТЧ.Номенклатура.НаименованиеПолное);
			ОбластьСтроки.Параметры.ИнвНомер = СтрокаТЧ.Номенклатура.Код;
			ЕдиницаИзмерения =  Строка(ЕдиницаИзмеренияНоменклатуры(СтрокаТЧ.Номенклатура)) + ".";
			ОбластьСтроки.Параметры.ЕдиницаИзмерения = ?(ЕдиницаИзмерения <> Неопределено, ЕдиницаИзмерения, "<не указана>");
			ОбластьСтроки.Параметры.Количество = СтрокаТЧ.Количество;
			ТабДокумент.Вывести(ОбластьСтроки);
		КонецЦикла;
		
		ОбластьМакета = Макет.ПолучитьОбласть("Середина");
		ТабДокумент.Вывести(ОбластьМакета);
		
		ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
		
		СотрудникОтветственный = СсылкаНаОбъект.Ответственный.ФизЛицо; 
		ОбластьМакета.Параметры.ДолжностьСдал = ПолучитьДолжностьСотрудника(СотрудникОтветственный);
		ОбластьМакета.Параметры.РасшифровкаСдал = РазборФИО(СотрудникОтветственный.Наименование);
		ОбластьМакета.Параметры.ДолжностьПринял = ПолучитьДолжностьСотрудника(Сотрудник);
		ОбластьМакета.Параметры.РасшифровкаПринял = РазборФИО(Сотрудник.Наименование);
		ТабДокумент.Вывести(ОбластьМакета);
	Возврат ТабДокумент;
	КонецФункции
	
	Функция ПечатьАкта()
		ТабДокумент = ПечатьАктаОПриемеПередачеМатериальныхЦенностей();
		Возврат ТабДокумент;
	КонецФункции
	
	Функция Печать() Экспорт
		Если ТипЗнч(СсылкаНаОбъект) = Тип("ДокументСсылка.ПередачаМатериаловВЭксплуатацию") Тогда
			Возврат ПечатьАкта();
		КонецЕсли;
	КонецФункции
#КонецЕсли

Если речь о внешней печатной форме, то можете саму обработку тут выложить?

Спасибо, что откликнулись. Вот сам файл 

Прикреплённые файлы: 

Почему то скрины не выклвадываются?

Для вставки картинки нужно после загрузки картинки нажать кнопку "Вставить". Подробнее описано тут.

Обработка, которую Вы выложили, - это просто шаблон внешней печатной формы. Нужна ВПФ , которая используется в БП 2.0.

Это?

Прикреплённые файлы: 

Надо полностью код обработки переписывать. Вам без знаний в области программирования 1С не справиться. Могу сделать за умеренную плату.

Спасибо. Умеренная-это сколько? Просто мое руководство на это денег не выделяет, придется из своего кармана

Написал на почту, указанную в профиле.