Передать команду по нажатию кнопки из Документа1 в Документ2

Версия для печатиPDF-версия

Добрый вечер. Собственно вопрос: есть два Документа 1.ОтчетКассира и 2.Ведомость. В 1 документе(ОтчетКассира) на Форме есть объект типа Булево(флажок), а в документе2(Ведомость) есть Кнопка. Необходимо сделать так, чтобы в документе2 нажав на Кнопку, в документе1 поставилась галочка. Никак не могу реализовать это....(( помогите плиз. Заведомо ПРЕМНОГО БЛАГОДАРЕН)
 

пробовал так, но при выполнении выдает ошибку  {Документ.ПрепроводительнаяВедомость.Форма.ФормаДокумента.Форма(35)}: Поле объекта недоступно для записи (ДеньгиОтправлены)
    проставить.ДеньгиОтправлены=Истина;

Процедура Заполнить(Команда)
    
    проставить = Документы.ОтчетКассира.Выбрать();
    проставить.ДеньгиОтправлены=Истина;
    ЭтаФорма.Закрыть();
    
КонецПроцедуры

"В 1 документе(ОтчетКассира) на Форме есть объект типа Булево(флажок)" - этот объект типа Булево является реквизитом документа ОтчетКассира или реквизитом формы?

да, является, реквизит документа.
 

Если так, то последовательность действий такая:

1. Получить ссылку на конкретный документ ОтчетКассира (возможно из свойства ДокументОснование документа Ведомость или каким-либо иным путём).

2. Получить объект документа ОтчетКассира методом ссылки ПолучитьОбъект().

3. Установить свойство объекта ДеньгиОтправлены в Истина.

4. Записать объект ОтчетКассира.

Всё это выполняется разумеется на сервере.

Значение по умолчанию должно стоять Ложь, а вот уже при нажатии кнопки должно проставлять истину. Но я попробую описанное выше. Спасибо

Тут самое главное получить ссылку нужного документа ОтчетКассира. В документе Ведомость есть какая-нибудь привязка к ОтчетуКассира?

да, есть. ТабличныеЧасти.ТабличнаяЧастьВедомость.РеквизитОтчетКассира.

Тогда можно использовать подобный код:

&НаКлиенте
Процедура Заполнить(Команда)
	ЗаполнитьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьНаСервере()
	Для Каждого СтрокаТЧ Из Объект.Ведомость Цикл 
		ОтчетКассираОбъект = СтрокаТЧ.ОтчетКассира.ПолучитьОбъект();
		Если ОтчетКассираОбъект = Неопределено Тогда 
			Продолжить;
		КонецЕсли;
		ОтчетКассираОбъект.ДеньгиОтправлены = Истина;
		Попытка
			ОтчетКассираОбъект.Записать();
		Исключение
			Сообщить(ОписаниеОшибки());
		КонецПопытки;
	КонецЦикла;
КонецПроцедуры

Низкий вам поклон) спасибо) все сработало!