Отладка ВПФ управляемого приложения

Версия для печатиPDF-версия

Платформа:

Доброго дня, уважаемые!

Кто подскажет (возможно, даст код с пояснениями) - как вызвать отладку внешней печатной формы УПРАВЛЯЕМОГО приложения. Сколько смотрел разных советов - ни один не помог.

Конф-я - ERP 2.0

Можно добавить форму обработки. На форму вывести реквизит Документ со значением типа ДокументСсылка.<ИмяПечатаемогоДокумента>. Добавить команду Печать.

Примерный код обработчика команды Печать такой:

&НаСервере
Функция ПечатьНаСервере()
	МассивОбъектов = Новый Массив;
	МассивОбъектов.Добавить(Документ);
	КоллекцияПечатныхФорм = УправлениеПечатью.ПодготовитьКоллекциюПечатныхФорм(<ИдентификаторКоманды>);
	ПараметрыВывода = УправлениеПечатью.ПодготовитьСтруктуруПараметровВывода();
	ОбъектыПечати = Новый СписокЗначений;
	ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
	ОбработкаОбъект.Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода);
	Возврат КоллекцияПечатныхФорм.ВыгрузитьКолонку("ТабличныйДокумент");
КонецФункции

&НаКлиенте
Процедура Печать(Команда)
	МассивТабличныхДокументов = ПечатьНаСервере();
	Для Каждого ТабличныйДокумент Из МассивТабличныхДокументов Цикл 
		Если ТабличныйДокумент <> Неопределено Тогда 
			ТабличныйДокумент.Показать();
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры

Этот код для УТ 11.1. По идее и в ERP 2.0 должен работать.

Как то так?

Прикреплённые файлы: 

В общем, да.

Только в строке

КоллекцияПечатныхФорм = УправлениеПечатью.ПодготовитьКоллекциюПечатныхФорм(Макет);

нужно не макет передавать, а идентификатор команды печати, как он прописан  в функции СведенияОВнешнейОбработке() модуля объекта обработки. В вашем случае "ИнвентарнаяКарточкаОС6".

Благодарю за пояснение. 

Вроде всё стройно выглядит, но теперь при выполнении печать спотыкается на первом же параметре макета - поле объекта не обнаружено
 

Ставьте точку останова и смотрите в отладчике.

Сердечно благодарю всех участников обсуждения!