Ошибка в расчете начисления

Версия для печатиPDF-версия

Платформа:

Сейчас создаю БД по книге Радченко и Хрусталевой. Успешно дошли до расчетов по з/пл. Далее ввожу код в общий модуль в процедуру "Рассчитать начисления" как в книге:

      Для Каждого ЗаписьРегистра Из НаборЗаписейРегистра Цикл
         СтруктураНомер = Новый Структура("НомерСтроки");
         СтруктураНомер.НомерСтроки = ЗаписьРегистра.НомерСтроки;
         ВыборкаРезультата.Сбросить();
         
         Если ВыборкаРезультата.НайтиСледующий(СтруктураНомер) Тогда
            
            Если ВыборкаРезультата.Норма = 0 Тогда
               Сообщение = Новый СообщениеПользователю;
               Сообщение.Текст = "ВидРасчета: Оклад - Нет рабочих дней в заданном периоде";
               Сообщение.Сообщить();
               ЗаписьРегистра.Результат = 0;
            Иначе
               //Рассчитать оклад по фактическому периоду и исходным данным
               ЗаписьРегистра.Результат = (ЗаписьРегистра.ИсходныеДанныеВыборкаРезультата.Норма)*(ВыборкаРезультата.Факт);
               Сообщение = Новый СообщениеПользователю;
               Сообщение.Текст = "Выполнен расчет " + ЗаписьРегистра.Регистратор
                     + "-" + ЗаписьРегистра.ВидРасчета + "-" +
                     ЗаписьРегистра.Сотрудник;
               Сообщение.Сообщить();
            КонецЕсли
            
         КонецЕсли
      КонецЦикла   
....и вижу, что при отладке наверняка будет ошибка в строке "ЗаписьРегистра.Результат = (ЗаписьРегистра.ИсходныеДанныеВыборкаРезультата.Норма)*(ВыборкаРезультата.Факт);"

Запускаю отладку, нажимаю, "Провести".
Получаю сообщение:

"Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{ОбщийМодуль.ПроведениеРасчетов.Модуль(39)}: Поле объекта не обнаружено (ИсходныеДанныеВыборкаРезультата)
               ЗаписьРегистра.Результат = (ЗаписьРегистра.ИсходныеДанныеВыборкаРезультата.Норма)*(ВыборкаРезультата.Факт);"

Кто подскажет, в чем дело? Если я, новичок в 1С , догадывался что там , в этой стоке есть ошибка.
 

Да в общем-то, в сообщении всё понятно написано: "Поле объекта не обнаружено". В регистре есть измерение или ресурс ИсходныеДанныеВыборкаРезультата?

В регистре расчета есть реквизит "ИсходныеДанные".
 

Тогда ИсходныеДанные и надо использовать.

Тогда при отладке возникает другое сообщение:

 

Ошибка при выполнении обработчика - 'ОбработкаПроведения'
по причине:
{ОбщийМодуль.ПроведениеРасчетов.Модуль(39)}: Значение не является значением объектного типа (Норма)
                    ЗаписьРегистра.Результат = (ЗаписьРегистра.ИсходныеДанные.Норма)*(ВыборкаРезультата.Факт);

У ИсходныеДанные какой тип?

число

Соответственно, у них не может быть реквизита Норма.

В учебном пособии ошибка(ПППЦ) Я очень ругался. Пропустили знал деления.
ЗаписьРегистра.Результат = (ЗаписьРегистра.ИсходныеДанные/
ВыборкаРезультата.Норма)* ВыборкаРезультата.Факт;