Ошибка в общем модуле

Версия для печатиPDF-версия

Платформа:

В Расходной накладной в табличной части есть реквизит ЕдиницаИмерения. При этом значение табличной части Сумма зависит от того, в какой единицы измерения выводится товар. Есть регистр сведений ЕдиницыИзмерения, где хранится название и коэффециент. Задачу решаю следующим образом. В общем модуле я обращаюсь к этому регистру и вытаскиваю значение коэффециента:

Функция ВыводКоэффециента(ЭлементЕдиницыИзмерения) Экспорт
    Отбор = Новый Структура("ЕдиницыИзмерения", ЭлементЕдиницыИзмерения);
    ЗначенияРесурсов = РегистрыСведений.ЕдиницыИзмерения.Получить(Отбор);
    Возврат ЗначенияРесурсов.Коэффециент;
КонецФункции 

В форме документа в модуле команды я обращась к этому модулю:

&НаКлиенте
Процедура Заполнить(Команда)
    Перем ВидЦены;
    Перем ПараметрЕдиницыИзмерения;
    Для Каждого СтрокаТаблицы Из Объект.Товары Цикл
        ВидЦены = Объект.ВидЦен;
        ПараметрЕдиницыИзмерения = ЕдИзмер.ВыводКоэффециента( СтрокаТаблицы.ЕдиницаИзмерения);
        СтрокаТаблицы.ВидЦены = ВидЦены;
        СтрокаТаблицы.Цена = РаботаСЦенами.РозничнаяЦена(Объект.Дата, СтрокаТаблицы.ВидЦены, СтрокаТаблицы.ВидМеталла);
        СтрокаТаблицы.Стоимость = СтрокаТаблицы.Цена * СтрокаТаблицы.Количество * ПараметрЕдиницыИзмерения;
    КонецЦикла;
КонецПроцедуры

Когда я нажимаю на эту команду в пользовательском режиме, то пишет  Недопустимое значение параметра (параметр номер '1'). В чём я допустил ошибку?

 

Ошибку сам нашел и исправил. Неправильно обращался к регистру сведений.