Обыкновенное уравнение (в отчёте)

Версия для печатиPDF-версия

Это сложение двух чисел, записанных, например, в ячейки R1C1 и R1C2, результат в R1C3 (по всем строкам, R1-Rn)

&НаКлиенте
Процедура ТабДокПриИзмененииСодержимогоОбласти(Элемент, Область)

ПриИзмененииДанныхОбластиТабДока(Элемент, Область, ЭтаФорма);

КонецПроцедуры


&НаКлиенте
Функция ПриИзмененииДанныхОбластиТабДока(Элемент, Область, Контекст) Экспорт 

ПозицияКолонки = Найти(Область.Имя,"C");
Строка = Сред(Область.Имя, 1, ПозицияКолонки-1);
Колонка = Сред(Область.Имя, ПозицияКолонки);

Если Колонка = "C1" или Колонка = "C2" Тогда
Попытка
Контекст[Элемент.Имя].Область(Строка+"C3").Текст = Число(Контекст[Элемент.Имя].Область(Строка+"C2").Текст) + Число(Контекст[Элемент.Имя].Область(Строка+"C1").Текст);
Исключение 
КонецПопытки; 
КонецЕсли; 

КонецФункции

А как реализовать решение системы уравнений? Хотя бы типа таких?
x-y=-5
2x+y=-7