Обыкновенное уравнение (в отчёте)

Версия для печатиPDF-версия

Отчёт->макет->табличный документ насколько я понимаю...

К примеру, в ячейке r1c1 задано значение x1, в r1c2 значение x2, а в r1c3 должна получиться сумма x1 и x2. Как это правильно записать на встроенном языке?

Процедура ПолеТабличногоДокументаПриИзмененииСодержимогоОбласти(Элемент, Область)
ТабДок.Область("R1C3").Текст = Число(ТабДок.Область("R1C1").Текст) + Число(ТабДок.Область("R1C2").Текст);
КонецПроцедуры

P.S. Посоветуйте литературу по теме

А зачем производить вычисления в самом отчёте? Может быть проще использовать таблицу формы, а потом уже вывести результаты в печатную форму?

Так нужно...Знаете, как грамотно это написать?

Можно что-нибудь в таком духе написать:

Процедура ПолеТабличногоДокументаПриИзмененииСодержимогоОбласти(Элемент, Область)
	ИмяОбласти = Область.Имя;
	Если ИмяОбласти = "R1C1" Или ИмяОбласти = "R1C2" Тогда 
		ТабДок = ЭлементыФормы.ПолеТабличногоДокумента;
		ТабДок.Область("R1C3").Текст = ПреобразоватьВЧисло(ТабДок.Область("R1C1").Текст) + ПреобразоватьВЧисло(ТабДок.Область("R1C2").Текст);
	КонецЕсли;
КонецПроцедуры

Функция ПреобразоватьВЧисло(Текст)
	Попытка
		Значение = Число(Текст);
	Исключение
		Значение = 0;
	КонецПопытки;
	Возврат Значение
КонецФункции

ПС. Непонятно, что у вас в ТабДок находится.

 &НаКлиенте
Процедура ТабДокПриИзмененииСодержимогоОбласти(Элемент, Область)
 
ПриИзмененииДанныхОбластиТабДока(Элемент, Область, ЭтаФорма);
 
КонецПроцедуры
 
 
&НаКлиенте
Функция ПриИзмененииДанныхОбластиТабДока(Элемент, Область, Контекст) Экспорт 
 
ПозицияКолонки = Найти(Область.Имя,"C");
Строка = Сред(Область.Имя, 1, ПозицияКолонки-1);
Колонка = Сред(Область.Имя, ПозицияКолонки);
 
Если Колонка = "C1" или Колонка = "C2" Тогда
Попытка
Контекст[Элемент.Имя].Область(Строка+"C3").Текст = Число(Контекст[Элемент.Имя].Область(Строка+"C2").Текст) + Число(Контекст[Элемент.Имя].Область(Строка+"C1").Текст);
Исключение
КонецПопытки;
КонецЕсли; 
 
КонецФункции
 
Это сложение двух чисел, а как реализовать решение системы уравнений? Хотя бы типа таких?
x-y=-5
2x+y=-7

И что вы хотите получить на выходе?

Получить значения x и y

Алгоритм надо самому прописывать.