Обмен контрагентами

Версия для печатиPDF-версия

Здравствуйте!

Как создать правило обмена, согласно которому контрагенты одной базы (БП 2.0) "подтянутся" в папку (группу) контрагентов другой (УПП 1.3)?
 

По-моему, самый простой способ в обработчик "После загрузки" правила конвертации объектов Контрагенты добавить следующий код:

Если Не ОбъектНайден Тогда
	Объект.Родитель = Справочники.Контрагенты.НайтиПоКоду(<КодВБазеПриемнике>);
КонецЕсли;

К сожалению, не работает
 

Ошибку выдаёт?

Нет.

До этих действий была проведена загрузка, т.е. контрагенты уже были в приёмнике.

Соответственно, они не новые и, видимо, поэтому не работало условие. Убрал "если" - нужный результат.

Благодарю Вас!
 

Успех оказался преждевременным - в УПП не подгрузились банковские счета и договоры контрагентов. Т.е. названия их есть, а внутри пусто. Попробовал в правило Контрагенты обработчик "После загрузки" дописать такой код:

Если Объект.ОсновнойДоговорКонтрагента.ВидДоговора = "СПокупателем" Тогда
    Справочник.Контрагенты.Покупатель = Истина
ИначеЕсли Объект.ОсновнойДоговорКонтрагента.ВидДоговора = "СПоставщиком" Тогда
    Справочник.Контрагенты.Поставщик = Истина
КонецЕсли;
КонецЕсли;

и при загрузке выходит ошибка (скрин приложен). Что не так?

offtopic: Не получается прикладывать скриншоты в виде рисунков - выдается сообщение о попытке подбора captcha.

Прикреплённые файлы: 

Вы с нуля правила пишите?

А правила конвертации объектов для договоров и счетов у вас созданы?

Теперь по поводу ошибки.

Во-первых, попробуйте после "= Истина" поставить ";".

Во-вторых, почему у вас в конце 2 раза "КонецЕсли;"?

В-третьих, (это к ошибке не относится) ВидДоговора имеет тип ПеречислениеСсылка.ВидыДоговоровКонтрагентов, а не Строка. Ваши условия всегда будут ложны.