не обновляется уже открытая форма после изменений в табличной части

Версия для печатиPDF-версия

Платформа:

Создана внешняя обработка. Добавляется кнопкой в документ в 1С ЗУП 3.1 в документ ДанныеДляРасчетаЗапрлаты. В открытой форме нажатие на кнопку вызывает обработку, делает изменения, но форма не обновляется. Ф-ция Сообщить выдает правильные результаты изменений.Что не так в коде, может был такой же вопрос? Если такой код запускаю в документе РазовоеНачисление - все работает.
 
&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды,ОбъектыНазначенияМассив) Экспорт
   ВладелецФормы.Модифицированность = Истина;
   ОснРеквизит1 = ВладелецФормы.Объект;      
   ЗаполнитьОбъект(ОснРеквизит1);
   КопироватьДанныеФормы(ОснРеквизит1,ВладелецФормы.Объект);
КонецПроцедуры
&НаСервере
Функция ЗаполнитьОбъект(ОснРеквизит1)
   ТЧ =ОснРеквизит1.ЗначенияПоказателей; 
   Для Каждого Строка ИЗ ТЧ Цикл
      Если СтрСравнить(Строка.Показатель, "СдельноНорма") = 0 Тогда
         Строка.Значение = Строка.Значение -15;
                        Сообщить(Строка.Показатель);
                  Сообщить(Строка.Значение);
           КонецЕсли;
        КонецЦикла;
КонецФункции
 

Этот код из документа или из обработки?

Этот код лежит во внешней обработке, которая отрабатывает в открытой форме документа кнопкой.

Неплохо бы взглянуть на обработку и на её вызов из конфигурации.

 вызов через кнопку заполнить. внизу сообщения с результатами расчетов. дело в том, что это был созданный шаблон для ввода документа, которого нет в конфигурации.

Прикреплённые файлы: