Код обработки Свойств номенклатуры не добавляет значения

Версия для печатиPDF-версия
Обработка загружает из EXCEL свойства номенклатуры. Cуть в том, что они добавлятся только в новую, создаваемую номенклатуру. А вот если я хочу обновить уже имеющуюся, то ничего не происходит.
Помогите исправить КОД что бы при обновлении значение тоже записывалось. А лучше проверялось, есть такое или нет в справочнике ЗначенияСвойствОбъектов, если есть то бралось оттуда, если нет, тогда записывалось и подставлялось. Так избежим гору дублей свойств.
 
<blockcode>Процедура ЗаписатьСвойстваНоменлатуры(ТекущаяСтрокаТаблицы, ТекНом)
 
НаборЗаписейЗначенияСвойств = РегистрыСведений.ЗначенияСвойствОбъектов.СоздатьНаборЗаписей();
// Производитель
Если ЗначениеЗаполнено(КолонкаПроизводитель) Тогда 
Если ЗначениеЗаполнено(ТекущаяСтрокаТаблицы[КолонкаПроизводитель]) Тогда 
 
ЗначениеСвойства = Справочники.ЗначенияСвойствОбъектов.НайтиПоНаименованию(ТекущаяСтрокаТаблицы[КолонкаПроизводитель]);
Если ЗначениеСвойства.Пустая() Тогда
НовЗначСв = Справочники.ЗначенияСвойствОбъектов.СоздатьЭлемент();
НовЗначСв.Владелец = ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("Производитель");
НовЗначСв.Наименование = ТекущаяСтрокаТаблицы[КолонкаПроизводитель];
НовЗначСв.Записать();
ЗначениеСвойства = НовЗначСв.Ссылка;
КонецЕсли;
 
 
Запись = НаборЗаписейЗначенияСвойств.Добавить();
Запись.Объект   = ТекНом;
Запись.Свойство = ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("Производитель");
Запись.Значение = ЗначениеСвойства;
 
КонецЕсли;
КонецЕсли;
 
// ПартНомер
Если ЗначениеЗаполнено(КолонкаПартНомер) Тогда 
Если ЗначениеЗаполнено(ТекущаяСтрокаТаблицы[КолонкаПартНомер]) Тогда 
 
ЗначениеСвойства = Справочники.ЗначенияСвойствОбъектов.НайтиПоНаименованию(ТекущаяСтрокаТаблицы[КолонкаПартНомер]);
Если ЗначениеСвойства.Пустая() Тогда
НовЗначСв = Справочники.ЗначенияСвойствОбъектов.СоздатьЭлемент();
НовЗначСв.Владелец = ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("Код производителя, MPN");
НовЗначСв.Наименование = ТекущаяСтрокаТаблицы[КолонкаПартНомер];
НовЗначСв.Записать();
ЗначениеСвойства = НовЗначСв.Ссылка;
КонецЕсли;
 
Запись = НаборЗаписейЗначенияСвойств.Добавить();
Запись.Объект   = ТекНом;
Запись.Свойство = ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("Код производителя, MPN");
Запись.Значение = ЗначениеСвойства;
 
КонецЕсли;
КонецЕсли;
 
НаборЗаписейЗначенияСвойств.Отбор.Объект.Установить(ТекНом);
Попытка
НаборЗаписейЗначенияСвойств.Записать();
Исключение
КонецПопытки;
 
КонецПроцедуры
</blockcode>
 

Попробуйте отбор по номенклатуре поставить перед добавлением свойств.