Как сохранить в реквизите цвет?

Версия для печатиPDF-версия
1С 8.2 УТ 10.3
 
Хочется сделать справочник, с перечислением Станций и Веток Московского Метрополитена.
Реализовано по аналогии справочника КонтактныеЛицаКонтрагентов
 
В форме справочника два поля (с выпадающим списком) с реквизитами (Станция и Ветка) и представление в котором эти реквизиты записываются через пробел.
 
Все замечательно, вот только длиннннновато получается:
Нахимовский проспект Серпуховско-Тимирязевская
)))))
 
Подскажите, полалуйста, как можно (наиболее просто) реализовать запись Линии (ветки) другим способом?
Например:
Цвет текста ветки (вместо название ветки вносится символ “-” с соответствующим цветом)
Цветом текста в названии станции
Картинка – в поле ветка выбирается маленькая картинка (квадратик нужного цвета, соответствующего ветке), который в свою очередь отражается в представлении через пробел рядом со станцией.
Цвет поля представления.
Иное
 
Любой способ передачи цвета, который можно записать в реквизит представления, который в свою очередь можно будет использовать для отражения на формах, формах списка и табличных полях.
 
 

У Ветки добавить реквизит Цвет с типом значения ХранилищеДанных. В форме элемента справочника Ветки (надеюсь, это отдельный справочник?) выбирать цвет через ДиалогВыбораЦвета. При записи элемента помещать значение выбранного цвета в реквизит Цвет. Далее можно будет считывать это значение и использовать этот цвет хоть для фона, хоть для текста.

Поигрался, совет хороший.
Спасибо.

Получилась так:
В форму добавил реквизит Цвет.
Его Тип назначил Цвет.

Только я не умею использовать эти данные.
Т.е. я получаю: Синий (Blue) или 0, 0, 255 передаю эти данные реквизиту Справочника:


Процедура ЦветПриИзменении(Элемент)
	
	СправочникОбъект.Цвет = Цвет;
		
КонецПроцедуры

И, что с этим делать, пока не знаю.

Научите, пожалуйста, присваивать полученные данные шрифту, фону или любому другому виду отражения при выводе этих данных на форму документа или справочника.

Реквизит формы лучше назвать как-нибудь по-другому, чтобы не путаться. Например, ВыбранныйЦвет.

Запись выбранного цвета в реквизит объекта:

Процедура ПередЗаписью(Отказ)
	Цвет = Новый ХранилищеЗначения(ВыбранныйЦвет);
КонецПроцедуры

Получение цвета из реквизита объекта и раскраска фона элемента формы:

Процедура ПриОткрытии()
	ЦветИзХранилища = Цвет.Получить();
	Если ТипЗнч(ЦветИзХранилища) = Тип("Цвет") Тогда 
		ВыбранныйЦвет = ЦветИзХранилища;
	Иначе 
		ВыбранныйЦвет = Новый Цвет(255,255,255);
	КонецЕсли;
	ЭлементыФормы.Элемент.ЦветФона = ВыбранныйЦвет;
КонецПроцедуры