Как сделать поиск в табличной части по наибольшему совпадению символов?

Версия для печатиPDF-версия
Задумка:
Две табличные части
Таб1 и Таб2
В каждой одинаковые колонки.
Одна из колонок Наименование.
При активации строки Таб1, в Таб2 происходит отбор строк, по наилучшему совпадению текста в колонках наименования.
 
Обусловлено это тем, что в каждой организации по разному заполняют названия одних и тех же позиций.
Пример:
Сок яблочный 400 грамм.
Яблочный сок 400 грамм
400 грамм яблочного сока
Сок натуральный яблочный 400г.
Сок яблочный 0.4 л.
Сок яблочный 0,4 л.
Сок яблочный 0,4 л
Сок яблочный 0,4 литра
И т.д. и т.п.
Все это одна позиции, но как видите, метод найти(… не подойдет
 
Соответственно, не редко, при сопоставления прайса поставщика происходя казусы.
Так же хочу прикрутить в парсинг.
 
Думал о полнотекстовом поиске, но как прикрутить не понял
 
Подскажите, пожалуйста, в каком направлении стоит копать?
 

Артикулы не используются?

Артикли у всех свои.
 
Например, парсим сайт конкурента.
Чтобы сравнить цены, вдруг у нас завышены…
 
Или новый поставщик предлагает продукцию
Необходимо провести анализ – не пытается ли он задрать цены…
 
Или новый поставщик, хочет подменить старого, прислал предложение или прайс.
 
В этих и других случаях – артикул не совпадет никогда.
Придется искать вручную соответствия…
 
Поэтому и задумался, возможно ли создать инструмент – или прикрутить полнотекстовой поиск…
 

Полнотекстовый поиск, конечно, сильный инструмент, но с настройкой придётся попотеть...

Я уже придумал как.

И даже часть кода опробовал.

Если успею, сегодня покажу черновик.

У меня еще куча вопросов будет.

Наверняка, можно сократить и упростить, то что я напридумывал.

Сам я не нащупал...

Очень скудная инфо по этому вопросу....

Идея такая:
 
В таблице в которой необходимо искать добавляется колонка.
В нее циклом загоняется наименование в окружение фиктивных тегов и инфо о номере строки.
Строка.ДопКолонка =  "<Строка>"  +  "!!!!!"  +  Строка. НомерСтроки +  "ёёё" + Строка.Наименование + "</Строка>";
 
Затем, полнотекстовым поиском выводить в ПолеHTMLДокумента
Откуда записывать в файл и посредствам ПостроительDOM циклом собрать нужные строки в ТЗ.

 ЧтениеHTML1 = Новый ЧтениеHTML;
    ЧтениеHTML1.ОткрытьФайл(АдресСсылки1, "utf-8");    
    ПостроительDOM1 = Новый ПостроительDOM;
      ДокументHTML1 = ПостроительDOM1.Прочитать(ЧтениеHTML1);    
    
	СодержимоеТеговСтрока = ДокументHTML1.ПолучитьЭлементыПоИмени("Строка"); 
	
		Для Каждого СтрокаB Из СодержимоеТеговСтрока Цикл
		 НоваяСтрокаТЗ  = Тз.Добавить();
		НоваяСтрокаТЗ.НужнаяКОлонка  =  СтрокаB.ТекстовоеСодержимое;

		КонецЦикла;

 А уже в ТЗ получить  номера интересующих строк методом, котрым Вы меня научили в этом материале: http://novichok1c.ru/vopros/kak-nayti-tekst-mezhdu-sparsit


		СписокПоиска = ПолнотекстовыйПоиск.СоздатьСписок(ТекстПоиска,20);
		СписокПоиска.ПолучатьОписание = истина;
		МассивОтбор = Новый Массив();
			
		МассивОтбор.Добавить(Метаданные.Справочники.НужныйСправочник);
			
		СписокПоиска.ОбластьПоиска = МассивОтбор;
			
		СписокПоиска.ПорогНечеткости=25;
		СписокПоиска.СтрокаПоиска=ТекстПоиска;
		СписокПоиска.РазмерПорции = "20";
		СписокПоиска.ПерваяЧасть();

	Если СписокПоиска.ПолноеКоличество() = 0 Тогда
	   Если СписокПоиска.СлишкомМногоРезультатов() Тогда
	      Сообщить("Слишком много результатов, уточните запрос.");
	   КонецЕсли;
	   Возврат;
 	  КонецЕсли;
   
	Колво = СписокПоиска.ПолноеКоличество();
	
	СтрHTML = СписокПоиска.ПолучитьОтображение(ВидОтображенияПолнотекстовогоПоиска.HTMLТекст);

	ЭлементыФормы.ПолеHTMLДокумента.УстановитьТекст(СтрHTML);
	
	ПодключитьОбработчикОжидания("ЗапишемФайл", 3, Истина);
 
 
Вот обломился в (как мне казалось поначалу, простых вещах) том, что не могу представить, как можно в полнотекстовой поиск впихнуть данные конкретного элемента (или документа), а еще лучше конкретной таблицы, или табличной части, конкретного элемента (или документа)
 
Вот что получается:
Сколько не бился, не то, что получить и запихнуть в МассивОтбор нужную Таблицу, но даже вычленить Конкретный элемент справочника не смог….
 

 

Сегодня придумал следующее.

Сделать Документ, или справочник с одним - единственным элементом, с одной табличной частью и всякий раз его перезаполнять в процессе.

Таким образом будет поиск строго по одной таблице...