Action Coin

Как сделать чтобы ВПФ Товарный чек печаталась по нажатию кнопки пробить

Версия для печатиPDF-версия

Платформа:

Добрый день. Подскажите, пожалуйста, есть ВПФ Товарный чек. Нужно чтобы эта форма выводилась для печати при нажатии кнопки пробить в РМК после пробития чека. Как это сделать?

Включение ВПФ в конфигурацию не рассматриваете?

Можно внести, если надо

В обработчик команды "ПробитьЧек" нужно добавить подобный код:

&НаКлиенте
Процедура ПробитьЧек(Команда)
	...	
	ВПФ = НайтиВПФ();
	Если ВПФ.Пустая() Тогда
		Возврат;
	КонецЕсли;
	ОбъектыНазначения = Новый Массив;
	ОбъектыНазначения.Добавить(Объект.Ссылка);
	ПараметрыОткрытия = Новый Структура("ИсточникДанных, ПараметрыИсточника");
	ПараметрыОткрытия.ИсточникДанных = ВПФ;
	ПараметрыОткрытия.ПараметрыИсточника = Новый Структура("ИдентификаторКоманды, ОбъектыНазначения");
	ПараметрыОткрытия.ПараметрыИсточника.ИдентификаторКоманды = ИдентификаторКомандыПечати;
	ПараметрыОткрытия.ПараметрыИсточника.ОбъектыНазначения = ОбъектыНазначения;
	ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия);	
КонецПроцедуры

&НаСервереБезКонтекста
Функция НайтиВПФ()
	Возврат Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(НаименованиеВПФ);
КонецФункции

ИдентификаторКомандыПечати и НаименованиеВПФ нужно свои подставить.

Спасибо. А печатную форму надо сначала сделать встроенной?

Нет. Этот код для запуска зарегистрированной внешней печатной формы.

Большое спасибо