Как работать с ondatasetcomplete в HTML поле на управляемых формах?

Версия для печатиPDF-версия

Платформа:

Перевожу работу яндекс карты на управляемую форму.
Столкнулся с тем, что в HTML поле отсутствует событие ondatasetcomplete…
На толстом клиенте получал информацию о маршруте так:
 

Процедура Эксплорерondatasetcomplete(Элемент, pEvtObj)		
	Если ИсточникСобытийКарты = "Маршрут" Тогда
		ИнформацияОМаршруте =  ЭлементыФормы.Эксплорер.document.getElementById("RouteInfo").value;

		//удалить символы HTML
		Пока Истина Цикл   //удаление символов вида  
			ПозицияНач = Найти(ИнформацияОМаршруте, "&");
			Если ПозицияНач = 0 Тогда
				Прервать;
			КонецЕсли;
			
			ПозицияКон = Найти(ИнформацияОМаршруте, ";");
			Если ПозицияКон = 0 Тогда
				Прервать;
			КонецЕсли;
			ИнформацияОМаршруте = Сред(ИнформацияОМаршруте, 1, ПозицияНач - 1) + Сред(ИнформацияОМаршруте, ПозицияКон + 1);
		КонецЦикла;
		
		ДополнительнаяИнформация = ИнформацияОМаршруте;
	КонецЕсли;
	
	    Сообщить(ЭлементыФормы.Эксплорер.document.getElementById("InfoUID").value);
	
КонецПроцедуры

В макете прописано:
 
        //заполняем и сохраняем инфо про маршрут
        document.getElementById('RouteInfo').value = "Длина маршрута - " + route.getHumanLength() + ". Время - " + route.getHumanJamsTime();
        
        //генерация события для перехвата в 1С
        var evt = document.createEventObject();
  document.body.fireEvent('ondatasetcomplete', evt);
 
 
И не нашел никакой иной передачи ((((
Есть возможность получать инфо из HTML поля?
 
 
Временно выкрутился через onclick.
В макете:
document.body.fireEvent('onclick', evt);
В Модуле:

&НаКлиенте
Процедура ЭксплорерПриНажатии(Элемент, ДанныеСобытия, СтандартнаяОбработка)
	
	Если ИсточникСобытийКарты = "Маршрут" Тогда
	ПодключитьОбработчикОжидания("Эксплорерondatasetcomplete", 3, Истина);		
	ИсточникСобытийКарты = "";
	Иначе 	
		ПолучитьКоординаты();
	КонецЕсли;
КонецПроцедуры
Но это неправильно!
И почему-то без задержки на 3 секунды не отражаются данные (только при повторном выполнении), видимо передает в 1С раньше, чем рассчитает маршрут…(((
 
Может есть какой-то способ подключения обработчиков, например ondatasetcomplete?