Action Coin

Как получить значения текущей ячейки?

Версия для печатиPDF-версия

Начну от мамонтов.

Имеется Список Документа.

В нем сейчас множество колонок, для того, чтобы не покупать мониторы оооочеееень широкий )))), решили сделать внизу формы ПолеВводаЛупа, в котором будет отражаться значения из ячеек колонок.

Т.е. пример, строка комментария в узенькой колонке трудно читаемо, либо раздвигать колонку, либо выводить куда-то.

Подобное реализовано в excel.

Вы уже научили как данные из определенной колонке на строке получать, тут: http://novichok1c.ru/vopros/vybor-iz-spiska-v-yacheyke-tablichnogo-polya-v-spiske-zakazov-pokupatelya

Еще раз ОГРОМНОЕ СПАСИБО!

И вот я пробую в процедуре СписокПриАктивизацииЯчейки тем же методом.

А оказывается ТекущаяЯчейка не существует…

А как же?

Пробовал – ДанныеСтроки применить.

Пока не догоняю как.

Подскажите, пожалуйста.

Попробовал так:


	     ТекущаяОбласть = Элемент.ТекущаяКолонка.Данные;
	     ПолеВводаЛупа = ТекущаяОбласть;

 

Так он мне имена колонок дает..(((

А так:


значение = ЭлементыФормы.Список.ТекущаяСтрока;

Имя документа.

Пробую в морской бой:


  ТекущаяОбласть = Элемент.ТекущаяКолонка.Данные;
  
  значение = ЭлементыФормы.Список.ТекущаяСтрока.ТекущаяОбласть;
  
		 ПолеВводаЛупа = значение ;

Ругается...

 

 

Попробуйте создать такой обработчик события табличного поля ПриАктивизацииЯчейки:

Процедура СписокПриАктивизацииЯчейки(Элемент)
	ТекущиеДанные = Элемент.ТекущиеДанные;
	Если ТекущиеДанные = Неопределено Тогда 
		Возврат;
	КонецЕсли;
	ПолеВводаЛупа = ТекущиеДанные[Элемент.ТекущаяКолонка.Имя];
КонецПроцедуры
Отлично!
Огромное спасибо.
Содержимое ячеек колонок с реквизитами – выводит на ура.
С ячейками колонок без прямых реквизитов – выдает ошибку.
Например:
 Колонка Картинка в которой отражается картинка с отметкой на удаление.
Или колонка с представлением

		Если ДанныеСтроки.Ссылка.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ФизЛицо Тогда 
    	ОформлениеСтроки.Ячейки.Получатель.Текст = ""+ДанныеСтроки.Ссылка.КонтактноеЛицоКонтрагента+" "+ДанныеСтроки.Ссылка.УдостоверениеЛичностиКонтактногоЛицаКонтрагента;
    	Иначе  	ОформлениеСтроки.Ячейки.Получатель.Текст = ДанныеСтроки.Ссылка.Грузополучатель;
  		КонецЕсли;
При открытии списка – сразу выдает ошибку.
 
Вышел из положения просто, у подобных колонок в палитре свойств отключил галочку в пункте Доступность.
 
 

 

А вот сейчас понадобилось выводить в ПолеВводаЛупа значение «неродных ячеик»
Например, выведенных так:

	 	ОформлениеСтроки.Ячейки.КомментарийЗаказа.ОтображатьКартинку = Ложь;
		ОформлениеСтроки.Ячейки.КомментарийЗаказа.ОтображатьТекст    = Истина;
		ОформлениеСтроки.Ячейки.КомментарийЗаказа.ОтображатьФлажок   = Ложь;
		         ОформлениеСтроки.Ячейки.КомментарийЗаказа.УстановитьТекст(ДанныеСтроки.Сделка.Комментарий);
Это возможно?

Можно как-нибудь так:

Процедура СписокПриАктивизацииЯчейки(Элемент)
	ТекущаяСтрока = Элемент.ТекущаяСтрока;
	Если ТекущаяСтрока = Неопределено Тогда 
		Возврат;
	КонецЕсли;
	ОформлениеСтроки = Элемент.ОформлениеСтроки(ТекущаяСтрока);
	Ячейка = ОформлениеСтроки.Ячейки[Элемент.ТекущаяКолонка.Имя];
	Если Ячейка.ОтображатьТекст Тогда 
		ПолеВводаЛупа = Ячейка.Текст;
	ИначеЕсли Ячейка.ОтображатьФлажок Тогда 
		ПолеВводаЛупа = Ячейка.ЗначениеФлажка;
	Иначе 
		ПолеВводаЛупа = Ячейка.Значение;
	КонецЕсли;
КонецПроцедуры

Очень здорово.

Для себя сделал отдельную форму и увеличил шрифт в ПолеВводаЛупа, теперь не так страдаю и очки иногда могу снять.

Оромущее спасибо!