Как отобразить картинку в ячейки формы списка?

Версия для печатиPDF-версия

Хочется вывести картинку в ячейку строки  ФормыСписка Документа, которая при изменения значения в реквизите, будет меняться на другую или третью..

Но пока и одну вывести не могу.

 

В процедуру СписокПриПолученииДанных(Элемент, ОформленияСтрок) присал следующий код:


		 Для Каждого ОформлениеСтроки ИЗ ОформленияСтрок Цикл
		
		ОформлениеСтроки.Ячейки.СтатусОплаты.ОтображатьКартинку = Истина;
		ОформлениеСтроки.Ячейки.СтатусОплаты.ОтображатьТекст    = Ложь;
		ОформлениеСтроки.Ячейки.СтатусОплаты.ОтображатьФлажок   = Ложь;
		ОформлениеСтроки.Ячейки.СтатусОплаты.Картинка = БиблиотекаКартинок.КартинкаОплата;

	КонецЦикла;

Однако картинка не выводится(((

Научите, пожалуйста, как правильно выводить?

Разобрался как менять цвет в колонке.

В табличном поле включаю процедуру СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

В ней:


Если ДанныеСтроки.Ссылка.ДокументГотов = Истина
	Тогда 
	ОформлениеСтроки.Ячейки.ДокументГотов.ЦветФона = Новый Цвет(255, 78, 170);
Иначе
ОформлениеСтроки.Ячейки.ДокументГотов.ЦветФона = Новый Цвет(65, 238, 255);

КонецЕсли;

 

Все отлично работает.

А вот так:


ОформлениеСтроки.Ячейки.СтатусДоговора.Картинка = БиблиотекаКартинок.КартинкаОплата;

Не работает(((

Сам разобрался.

Т.к. тема востребована и насколько я понял, многие новички ищут, то расскажу как сделал:

В Табличном поле Формы Спика Документа необходимо включить процедуру ПриВыводеСтроки

В ней необходим следующий код:

Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)


ОформлениеСтроки.Ячейки.СтатусДоговора.ОтображатьКартинку = Истина;
    	ОформлениеСтроки.Ячейки.СтатусДоговора.ОтображатьТекст    = Ложь;
    	ОформлениеСтроки.Ячейки.СтатусДоговора.ОтображатьФлажок   = Ложь;
			
    	Если ДанныеСтроки.Ссылка.ВашаКолонка = "ВашеЗначение1" Тогда 
    	    	ОформлениеСтроки.Ячейки. ВашаКолонка.Картинка = БиблиотекаКартинок.Картинка1;
    	ИначеЕсли  ДанныеСтроки.Ссылка. ВашаКолонка = " ВашеЗначение2" Тогда
        	ОформлениеСтроки.Ячейки. ВашаКолонка.Картинка = БиблиотекаКартинок. Картинка2;
    Иначе
    	ОформлениеСтроки.Ячейки. ВашаКолонка.Картинка = БиблиотекаКартинок. Картинка3;
  КонецЕсли; 

 

В колонке текст значений заменяется на соответствующие Картинки, которые Вы присвоили Значениям.

Ура!