Группа пользователей в Если, Или как узнать ГруппуПользователя У пользователя?

Версия для печатиPDF-версия

Найти пользователя не трудно:



ТекушийПользователь = ПользователиИнформационнойБазы.ТекущийПользователь();	
	Если Найти(ТекушийПользователь, "Скрипач Гедеван Александрович") > 0 Тогда
		Сообщить("Здрасте");	
КонецЕсли;

Но уже давно не могу найти человеческий способ находить группу пользователя.

Просторы  поисковиков не дали результата.

В итоге, поковырявшись, написал кривоватенькую процедурку:




	  ТекушийПользователь = ПользователиИнформационнойБазы.ТекущийПользователь();
		
		 Юзверь = Справочники.Пользователи.НайтиПоКоду(ТекушийПользователь);	 
		
		 СпрГппы = Справочники.ГруппыПользователей.НайтиПоНаименованию("Менеджеры");
		 
		 Искомый = СпрГппы.Ссылка.ПользователиГруппы.Найти(Юзверь.Ссылка, "Пользователь");
		 
		 Если Не Искомый = Неопределено Тогда 
			 
			Сообщить("Здрасте");
			 
		 КонецЕсли;

Подскажите, пожалуйста, нормальный способ.

Конечно, если дуркануть, можно и одной строкой:


		 Если Не Справочники.ГруппыПользователей.НайтиПоНаименованию("Менеджеры").Ссылка.ПользователиГруппы.Найти(Справочники.Пользователи.НайтиПоКоду(ПользователиИнформационнойБазы.ТекущийПользователь()), "Пользователь") = Неопределено Тогда 
			 
			 	    Сообщить("Здасти");
			 
		 КонецЕсли;

Но все одно, это не по-человечьи…

Правильнее, конечно, запрос использовать.

Что-то типа такого:

Запрос = Новый Запрос;
Запрос.Текст = 
	"ВЫБРАТЬ
	|	ГруппыПользователейПользователиГруппы.Пользователь
	|ИЗ
	|	Справочник.ГруппыПользователей.ПользователиГруппы КАК ГруппыПользователейПользователиГруппы
	|ГДЕ
	|	ГруппыПользователейПользователиГруппы.Ссылка.Наименование = &Наименование
	|	И ГруппыПользователейПользователиГруппы.Пользователь = &Пользователь";

Запрос.УстановитьПараметр("Наименование", "Менеджеры");
Запрос.УстановитьПараметр("Пользователь", Пользователи.ТекущийПользователь());

Результат = Запрос.Выполнить();
Если Не Результат.Пустой() Тогда 
	Сообщить("Здрасте");
КонецЕсли;

Ух.

О запросе, я как-то не подумал даже....

Спасибо.