Динамическое создание колонок тч

Версия для печатиPDF-версия

Платформа:

Управляемые формы. Ювелирка. Гружу ДБФ поставщика и мне нужно отражение таблицей на форме. Поставила на форму ТЗ таблица значений путь к данным ДБФ реквизит обработки табличная часть.

Процедура ЗагрузитьДБФНаСервере()
// Вставить содержимое обработчика.
ФайлDBF = Новый XBase;
ФайлDBF.ОткрытьФайл(ИмяФайлаDBF,,Истина);
ФайлDBF.Кодировка=КодировкаXBase.OEM;
ФайлDBF.Первая();
 
Для каждого Поле из ФайлDBF.поля цикл
    ТЗ.Колонки.Добавить(Поле.Имя);
КонецЦикла;
ЭтаФорма.Элементы.ТЗ.СоздатьКолонки();
Пока НЕ ФайлDBF.ВКонце() Цикл
НоваяСтрока = Объект.ДБФ.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрока,ФайлDBF);
ФайлDBF.Следующая();
КонецЦикла;
КонецПроцедуры
Ругаеться на свойство колонки и если как то обхожу на создатьколонки тоже. Если делаю через таблицу значений не указанную на форме, а потом загрузить, то грузит только значение первой колонки. Точно помню как то делала, а как не помню уже. Помогите плиз!

Этот код для обычных форм. Для управляемых немного посложнее.

Пример добавления колонок и заполнения таблицы есть в этой теме.