Блокировка проведение при перепроведение документов

Версия для печатиPDF-версия

Платформа:

Добрый день ! прошу помощи у знающих или встречающих подобные ситуации . При Перепровдении документов в конце месяца программа выдает ошибку "Не удалось провести документ...... заблокирован". Был один обмен отключила. Службу Агента 1с сервер перезапускала не помогает.  

Где еще смотреть?

Ошибка при перепроведении документа

Может у вас 2 сеанса с перепроведением запущено?

Проверьте список активных пользователей.

Если база серверная, то включите блокировку регламентных заданий.

НЕ помогло(((. 

База серверная . Сегодня утром меня осинило в документах  РТУ ПТУ ППИ ППВ и.т.д стоят значки блокировки. Дорабатывала не я . Как можно обойти эту блокировку при перепроведении документов.

Процедура ПередЗаписьюОбъекта(ОбъектИсточник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
Если НЕ Отказ Тогда
Если ОбъектИсточник.ЭтоНовый() Тогда
ОбъектИсточник.АвторДокумента = ПараметрыСеанса.ТекущийПользователь;
ИначеЕсли НЕ РольДоступна("мПолныйДоступКДокументам") Тогда
СтатусБлокировки = ПолучитьСтатусБлокировкиОбъекта(ОбъектИсточник.Ссылка);
Если СтатусБлокировки = Перечисления.мСтатусыБлокировкиОбъектов.Установлена Тогда
Отказ = Истина;
КонецЕсли;
//
Если НЕ Отказ И НЕ ЗначениеЗаполнено(ОбъектИсточник.АвторДокумента) Тогда
Если ЗначениеЗаполнено(ОбъектИсточник.Ответственный) Тогда
ОбъектИсточник.АвторДокумента = ОбъектИсточник.Ответственный;
Иначе
ОбъектИсточник.АвторДокумента = ПараметрыСеанса.ТекущийПользователь;
КонецЕсли;
КонецЕсли;
//
Если Отказ Тогда
Сообщить("Документ " + Строка(ОбъектИсточник.Ссылка) + " заблокирован.");
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецПроцедуры
 
Процедура ОбработкаПроведенияОбъекта(ОбъектИсточник, Отказ, Режим) Экспорт
Если НЕ Отказ Тогда
СоздатьЗаписьОСостоянииБлокировки(ОбъектИсточник.Ссылка, Перечисления.мСтатусыБлокировкиОбъектов.Установлена, Отказ);
КонецЕсли;
КонецПроцедуры
 
Процедура ПриЗаписиОбъекта(ОбъектИсточник, Отказ) Экспорт
Если НЕ Отказ Тогда
ТЗСтатусыБлокировкиОбъекта = РегистрыСведений.мБлокировкаОбъектовНаРедактирование.СрезПоследних(, Новый Структура("Объект", ОбъектИсточник.Ссылка));
Если ТЗСтатусыБлокировкиОбъекта.Количество() = 0 Тогда
СоздатьЗаписьОСостоянииБлокировки(ОбъектИсточник.Ссылка, Перечисления.мСтатусыБлокировкиОбъектов.Снята, Отказ);
КонецЕсли;
КонецЕсли;
КонецПроцедуры
 
Процедура СоздатьЗаписьОСостоянииБлокировки(ОбъектСсылка, СтатусБлокировки, Отказ = Ложь)
РС_МенеджерЗаписи = РегистрыСведений.мБлокировкаОбъектовНаРедактирование.СоздатьМенеджерЗаписи();
РС_МенеджерЗаписи.Активность = Истина;
РС_МенеджерЗаписи.Объект = ОбъектСсылка;
РС_МенеджерЗаписи.Период = ТекущаяДата();
РС_МенеджерЗаписи.СтатусБлокировки = СтатусБлокировки;
РС_МенеджерЗаписи.Пользователь = ПараметрыСеанса.ТекущийПользователь;
Попытка
РС_МенеджерЗаписи.Записать();
Исключение
Отказ = Истина;
Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецПроцедуры
 
Функция ПолучитьСтатусБлокировкиОбъекта(ОбъектСсылка)
ТЗСтатусыБлокировкиОбъекта = РегистрыСведений.мБлокировкаОбъектовНаРедактирование.СрезПоследних(, Новый Структура("Объект", ОбъектСсылка));
Если ТЗСтатусыБлокировкиОбъекта.Количество() > 0 Тогда
Возврат ТЗСтатусыБлокировкиОбъекта[0].СтатусБлокировки;
Иначе
Возврат Перечисления.мСтатусыБлокировкиОбъектов.Установлена;
КонецЕсли;
КонецФункции
Все что нашла, как сдесь обойти блокировку. 

У пользователя, под которым перепроводите документы, роль мПолныйДоступКДокументам включена?

Спасибо. после того как вам написала нашла косяк.))

Спасибо большое.