Создание нескольких печатных форм в одной обработке

Версия для печатиPDF-версия

Этап 1: Создание внешней обработки

1.1. Создаем внешнюю печатную форму как описано в статье Создание внешней печатной формы (пп.1.1 - 1.4).

1.2. Добавляем реквизит ДополнительныеПараметры с типом данных "Произвольный".

Реквизиты обработки Создание реквизита ДополнительныеПараметры

1.3. Копируем макеты или создаём свои.

Копирование макетов

1.4. В модуле объекта обработки создаём функцию Печать() с ключевым словом Экспорт.

1.5. В функции Печать() прописываем обработку дополнительных параметров подобную следующей:


Функция Печать() Экспорт
	
	Если ТипЗнч(ДополнительныеПараметры) = Тип("Структура") Тогда
		Если ДополнительныеПараметры.Свойство("ИмяМакета") Тогда
			ИмяМакета = ДополнительныеПараметры.ИмяМакета;
		КонецЕсли;
	КонецЕсли; 
	// Здесь описываем алгоритм заполнения печатных форм
КонецФункции 

1.6. Сохраняем обработку.

Этап 2: Регистрация внешних печатных форм

2.1. Добавляем внешнюю обработку в режиме Предприятие как описано в статье Создание внешней печатной формы (пп.2.1 - 2.5).

2.2. Устанавливаем в поле "Представление объекта" нужный документ или справочник. В поле "Заменяемая печатная форма" - заменяемую печатную форму.

2.3. Открываем форму задания параметров обработки.

Задание параметров обработки

2.4. В открывшейся форме нажимаем кнопку "Добавить".

Добавление дополнительного параметра

2.5. Задаём имя параметра, как оно задано в функции Печать() (см.п.1.5).

2.6. Выбираем тип значения дополнительного параметра (в данном примере - "Строка").

Выбор типа дополнительного параметра

2.7. Заполняем значение дополнительного параметра и нажимаем "Принять".

Значение дополнительного параметра

2.8. Добавляем новую строку в табличную часть "Принадлежность печатной формы".

Добавление новой строки принадлежности печатных форм

2.9. Выполняем с новой строкой действия 2.2 - 2.7.

Таблица Принадлежность печатной формы

2.10. Сохраняем внешнюю обработку.

Теперь при нажатии кнопки "Печать" в документе и выборе нужной формы будет вызываться нужная внешняя печатная форма.

Полезность материала: 
5
Ваша оценка: Нет Средняя: 5 (4 оценок)
Оцените полезность материала
© При копировании материалов сайта ссылка на оригинал обязательна.