Программная печать зарегистрированной внешней печатной формы

Версия для печатиPDF-версия

Иногда возникает необходимость программного вывода на печать внешней печатной формы. Ниже приведён пример кода для реализации такой задачи в конфигурациях, разработанных на основе библиотеки стандартных подсистем (БСП) 2.х.

&НаКлиенте
Процедура ПечатьВПФ(Команда)
	ВПФ = НайтиВПФ();
	Если ВПФ.Пустая() Тогда
		Возврат;
	КонецЕсли;
	ОбъектыНазначения = Новый Массив;
	ОбъектыНазначения.Добавить(Объект.Ссылка);
	ПараметрыОткрытия = Новый Структура("ИсточникДанных, ПараметрыИсточника");
	ПараметрыОткрытия.ИсточникДанных = ВПФ;
	ПараметрыОткрытия.ПараметрыИсточника = Новый Структура("ИдентификаторКоманды, ОбъектыНазначения");
	ПараметрыОткрытия.ПараметрыИсточника.ИдентификаторКоманды = ИдентификаторКомандыПечати1;
	ПараметрыОткрытия.ПараметрыИсточника.ОбъектыНазначения = ОбъектыНазначения;
	ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия);	
КонецПроцедуры

&НаСервереБезКонтекста
Функция НайтиВПФ()
	Возврат Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(НаименованиеВПФ2);
КонецФункции

1. ИдентификаторКомандыПечати - это идентификатор команды печати, указанный в функции СведенияОВнешнейОбработке() модуля объекта внешней печатной формы.

2. НаименованиеВПФ - наименование, под которым внешняя печатная форма зарегистрирована в базе..

Полезность материала: 
5
Ваша оценка: Нет Средняя: 5 (3 оценок)
Оцените полезность материала

Комментарии

отличный материал, в свое время все перерыл искал что-то подобное, сам разобрался.

Спасибо.

© При копировании материалов сайта ссылка на оригинал обязательна.