Открытие гиперссылок элемента ПолеHTMLДокумента в браузере

Версия для печатиPDF-версия

Элемент управления обычных форм ПолеHTMLДокумента переходит по ссылкам "внутри себя". Как сделать так, чтобы при нажатии на гиперссылку выбранная ссылка открывалась в браузере?

1. Для элемента ПолеHTMLДокумента добавляем обработчик события onсlick.

2. В процедуре-обработчике прописываем следующий код:

Процедура ПолеHTMLДокументаonclick(Элемент, pEvtObj)
	ТекЭлемент = Элемент.Документ.activeElement;
	Если НРег(ТекЭлемент.tagName) = "a" Тогда 
		Протокол = НРег(ТекЭлемент.protocol);
		Если Протокол = "http:" Или Протокол = "https:" Тогда 
			ЗапуститьПриложение(ТекЭлемент.href);
			pEvtObj.returnValue  = Ложь;
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры
Полезность материала: 
3
Ваша оценка: Нет Средняя: 3 (2 оценок)
Оцените полезность материала
© При копировании материалов сайта ссылка на оригинал обязательна.