Задачка

Версия для печатиPDF-версия
Доброе время суток, помогите пожалуйста с задачей, которая находится по этой ссылке http://school1c.ru/zadacha-1.html . Буду очень Вам признателен.
С чем возникли трудности? Задавайте конкретные вопросы, будем разбираться.
Вообще не имею предстваления с чего начинать. Где это нужно делать? Это возможно сделать во внешней обработке? Не имею предстваления что и как :(
Это не только возможно во внешней обработке, а именно в ней и делается.
Создаёте новую внешнюю обработку, создаёте форму обработки, добавляете необходимые реквизиты на форму, создаёте команды и обработчики к ним.
Судя по картинке, автор задачи работал с 7.7. В 8.2 интерфейс сильно отличается.
Хорошо, я сегодня вечером поделаю, но если что вы сможете мне помочь?
Будут вопросы - задавайте.
Спасибо
а это нужно делать в управляемом приложении или в обычном?
Ну это уж по желанию )) Можно сделать и там, и там.
Можете подсказать, что в данном коде подразумевается под названием "ТП"
ТП? Может быть ТЗ?
Вот так я сделал, но дальше не понимаю как код написать :(
Прикреплённые файлы: 
Заходишь в модуль формы и в каждом обработчике события пишешь нужный код. Методы объектов можно посмотреть в синтакс-помощнике.
а как таблицу умножения то сделать? :(
Только сейчас нашёл время разобраться.
Применительно к данной обработке код может быть такой:
&НаКлиенте
Процедура СоздатьТаблицуУмножения(Команда)
	СоздатьТаблицуУмноженияСервер();
КонецПроцедуры

&НаСервере
Процедура СоздатьТаблицуУмноженияСервер()
	Таблица1.Очистить();

	Элементы.Таблица1Таблица.Заголовок = " ";
	Элементы.Таблица1Таблица.ЦветФона = ЦветаСтиля.ЦветФонаКнопки;
	
	МассивРеквизитов = ПолучитьРеквизиты("Таблица1");
	// Проверяем, не были ли дополнительные колонки уже созданы
	Если МассивРеквизитов.Количество() = 1 Тогда 
		// В Таблица1 создаём 9 колонок (Число1 .. Число9). Каждая колонка - это реквизит формы с типом данных Число
		МассивДобавляемыхРеквизитов = Новый Массив; 
		Для Счетчик = 1 По 9 Цикл 
			МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Число" + Счетчик, Новый ОписаниеТипов("Число", Новый КвалификаторыЧисла(2, 0, ДопустимыйЗнак.Неотрицательный)), "Таблица1", Строка(Счетчик))); 
		КонецЦикла;
	    ИзменитьРеквизиты(МассивДобавляемыхРеквизитов);
		// Добавляем созданные колонки на форму. Каждая колонка - это элемент формы с типом ПолеФормы
		Для Счетчик = 1 По 9 Цикл 
		    НоваяКолонка = Элементы.Добавить("Таблица1Число" + Счетчик, Тип("ПолеФормы"), Элементы.Таблица1); 
		    НоваяКолонка.ПутьКДанным = "Таблица1.Число" + Счетчик;
		    НоваяКолонка.Вид = ВидПоляФормы.ПолеВвода; 
			НоваяКолонка.ТолькоПросмотр = Истина;
		КонецЦикла;
	КонецЕсли;
	
	// Заполняем таблицу умножения
	Для Счетчик = 1 По 9 Цикл 
		НоваяСтрока = Таблица1.Добавить();
		НоваяСтрока.Таблица = Счетчик;
		НоваяСтрока.Число1 = Счетчик;
		НоваяСтрока.Число2 = Счетчик * 2;
		НоваяСтрока.Число3 = Счетчик * 3;
		НоваяСтрока.Число4 = Счетчик * 4;
		НоваяСтрока.Число5 = Счетчик * 5;
		НоваяСтрока.Число6 = Счетчик * 6;
		НоваяСтрока.Число7 = Счетчик * 7;
		НоваяСтрока.Число8 = Счетчик * 8;
		НоваяСтрока.Число9 = Счетчик * 9;
	КонецЦикла;
КонецПроцедуры
Я не пойму, это код для какой кнопки, что-то я совсем запутался(( 
А вы могли бы решить полностью задачку? Я бы заплатил, если это будет необходимо. Потом бы поразбирался над выпоненной задачкой. Мне стыдно, что я прошу Вас об этом, Вы наверно думаете, что я совсем обнаглел, возможно Вы и будете правы, но беда в том, что я хочу изучить этот язык и мне нужно много примеров изучить, чтобы хоть разбираться в структуре. С конфигуратором у меня все получается, вот беда пока с кодом. Что вы ответите на этот вопрос? Спасибо 
В принципе, код можно к любой кнопке прикрутить. Первая процедура - это обработчик команды.
И сколько вы готовы заплатить?
Я не знаю, а какую сумму бы Вы назвали? 
Может быть стоит обратиться к Руководству разработчика? Платить за решение задачек для самообразования накладно выйдет.
вы получили мое сообщение? вы согласны?
Когда будет время, сделаю.
спасибо

Да. Верно. Я пробовала для своей задачки такое у меня обругалось на путь к данным. Недопустимое значение... Сейчас попробую еще раз, может пройдет.

Обалдеть! Все с первого раза встало! Спасибо!