Помогите с задачкой пожалуйста

Версия для печатиPDF-версия
Создать управляемую форму.
Разместить на ней:
* элементы ввода для задания пользователем диапазона целых чисел (например, от 0 и до 100).
* таблицу с колонками Число и Комментарий (строка).
 
После задания диапазона в таблице должны появиться все целые числа заданного диапазона (в колонке Число).
В колонке комментарий для каждого числа написать характеристику его делимости:
* если число делится на 3, - написать "Три",
* если число делится на 5, - написать "Пять",
* если число делится на 3 и на 5, - написать "Три, Пять".
 
Какая именно часть вызывает затруднения?
После задания диапазона в таблице должны появиться все целые числа заданного диапазона (в колонке Число).
В колонке комментарий для каждого числа написать характеристику его делимости:
* если число делится на 3, - написать "Три",
* если число делится на 5, - написать "Пять",
* если число делится на 3 и на 5, - написать "Три, Пять".
 
В общем-то всё элементарно. Вот примерный код процедуры заполнения таблицы:
&НаКлиенте
Процедура ЗаполнитьТаблицу(Команда)
	Таблица.Очистить();
	Для Индекс = Число1 По Число2 Цикл 
		НоваяСтрока = Таблица.Добавить();
		НоваяСтрока.Число = Индекс;
		Комментарий = "";
		Если Индекс <> 0 Тогда 
			ОстатокОтДеления = Индекс % 3;
			Если ОстатокОтДеления = 0 Тогда 
				Комментарий = "Три";
			КонецЕсли;
			ОстатокОтДеления = Индекс % 5;
			Если ОстатокОтДеления = 0 Тогда 
				Комментарий = ?(ПустаяСтрока(Комментарий), "", Комментарий + ", ") + "Пять";
			КонецЕсли;
		КонецЕсли;
		НоваяСтрока.Комментарий = Комментарий;
	КонецЦикла;
КонецПроцедуры
Вы лучший)) Огроооооомнейшее спасибо Вам! Буду чаще к Вам обращаться)) А можно спросить, на какой объект в клиенте вы щелкнули, чтобы в модуле определилась процедура ЗаполнитьТаблицу(Команда)?
Для этого нужно создать команду на одноименной вкладке. В свойставх созданной команды выбрать Действие и нажать на кнопку с лупой.
Можно посмотреть в прикреплённом файле.
Ааа, понял теперь. Еще раз огромное Вам спасибо.С Вашего позволения буду еще обращаться и простите за беспокойство если что))
Обращайтесь. Для этого и сайт создан )
Я сново по поводу вчерашнего кода. Нужно написать функцию отдеальн, ну в смысле тут же, которая бы возвращала комментарий к числу. Т.е. Из процедуры это удалит и чтобыцикл обращался к функции. Помогоите пожалуйста. 
 
Сказали, что просто нужно скомпановать для удобства, но я и представления не имею как ((
&НаКлиенте
Процедура ЗаполнитьТаблицу(Команда)
	Таблица.Очистить();
	Для Индекс = Число1 По Число2 Цикл 
		НоваяСтрока = Таблица.Добавить();
		НоваяСтрока.Число = Индекс;
		Если Индекс <> 0 Тогда 
			Комментарий = СформироватьКомментарий(Индекс, 3, "Три", "");
			Комментарий = СформироватьКомментарий(Индекс, 5, "Пять", Комментарий);
			НоваяСтрока.Комментарий = Комментарий;
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры

&НаКлиенте
Функция СформироватьКомментарий(Число, Делитель, ДелительСтрока, Комментарий)
	ОстатокОтДеления = Число % Делитель;
	Если ОстатокОтДеления = 0 Тогда 
		Комментарий = ?(ПустаяСтрока(Комментарий), "", Комментарий + ", ") + ДелительСтрока;
	КонецЕсли;
	Возврат Комментарий;
КонецФункции
Как-то так.
PS. Это тестовое задание или контрольная работа?
я просто устроился стажером в одну компанию, начальник просто дает всякие задачки, для того чтобы я практиковался.  Вы очень помогаете, по-тихоньку понимаю. А вообще, сложно выучить этот язык программирования? Я спрашиваю вас как программиста. Хотелось бы услышать Ваше мнение? Спасибо. 
В общем-то, сам язык программирования 1С не такой и сложный. Для изучения всегда можно использовать встроенный в конфигуратор синтакс-помощник. Кстати, очень полезная вещь.
Если есть знания других языков объектно-ориентированного программирования (Pascal, C++ и пр.), то сложностей при изучении не будет.
PS. Стажёром взяли вообще без знаний языка 1С?
В университете проходили, но правда поеверхностно. Мне почему то понравился данная среда разработки. Я хорошо владею языком рнр, но хочу изучать 1С. Я час на последнем курсе, а в универе не углубляются в ту или иную среду, дают так сказать небольшой фундамент, а дальше мол сам)) Начальник хороший попался, вот и взял меня, сказал, что дам шанс)) В дальнейшем хотел бы здесь работать и хочу изучить данный язык программирования. Вот. 
Понятно. Лично я начинал изучение 1С на курсах. Рекомендую Комплексный курс по конфигурированию в системе "1С:Предприятие 8".
Вы имеете в виду платные курсы?
И еще хотел спросить, а вот видеоуроков в торенатах куча, они как то дают представление о программировании в 1С. Может быть знаете каких нибудь авторов, чьи уроки следует смотреть? 
Про платные курсы - да.
Про видеокурсы ничего сказать не могу, т.к. сам ими не пользовался. Люди хвалят видеокурсы Чистова.
Спасибо. Ну если, что я еще буду к Вам обращаться)) Еще раз спасибо за уделенное вами мне время.